Bug 150359 - perl-DBI 1.47 is released
perl-DBI 1.47 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DBI (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 17:51 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 18:59:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-04 17:51:17 EST
Description of problem:
perl-DBI 1.47 was released in February 2005, while Fedora Core Development 
hangs around at version 1.40.

Version-Release number of selected component (if applicable):
perl-DBI-1.40-5

Actual results:
The following works for me:

--- snipp ---
--- perl-DBI.spec       2004-06-15 16:39:57.000000000 +0200
+++ perl-DBI.spec.rsc   2005-03-04 23:47:41.000000000 +0100
@@ -2,12 +2,12 @@

 Summary: A database access API for perl
 Name: perl-DBI
-Version: 1.40
-Release: 5
+Version: 1.47
+Release: 1
 URL: http://dbi.perl.org/
 License: Artistic
 Group: Applications/Databases
-Source: DBI-%{version}.tar.gz
+Source: http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
 Source2: filter-requires-dbi.sh
 Patch0: perl-DBI-1.37-prever.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -54,11 +54,13 @@

 %files -f %{name}-%{version}-filelist
 %defattr(-,root,root)
-%dir %{_libdir}/perl5/vendor_perl/%(perl -MConfig -le 'print "$Config{version}/$Config{archname}"')/DBI
-%dir %{_libdir}/perl5/vendor_perl/%(perl -MConfig -le 'print "$Config{version}/$Config{archname}"')/auto/DBI
-
+%dir %{perl_vendorarch}/DBI
+%dir %{perl_vendorarch}/auto/DBI

 %changelog
+* Fri Mar 04 2005 Robert Scheck <redhat@linuxnetz.de> 1.47-1
+- upgrade to 1.47
+
 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
 - rebuilt

--- snapp ---

Expected results:
Upgrade to 1.47 ;-)
Comment 1 Michael A. Peters 2005-03-13 17:07:00 EST
I would like to see this package update as well.

SlimServer 6 requires perl-DBI >= 1.46

Note You need to log in before you can comment on or make changes to this bug.