Bug 150363 - perl libwww-perl 5.803 is released
perl libwww-perl 5.803 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-libwww-perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
http://search.cpan.org/dist/libwww-perl/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 18:29 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.803-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 15:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff between Core CVS and spec file closer to the template (4.00 KB, patch)
2005-04-02 09:46 EST, Robert Scheck
no flags Details | Diff
Update and specfile cleanup (4.35 KB, patch)
2005-04-02 22:16 EST, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Robert Scheck 2005-03-04 18:29:22 EST
Description of problem:
perl libwww-perl 5.803 was released at December 11th, 2004 - while Fedora Core 
Development hangs around at version 5.79.

Version-Release number of selected component (if applicable):
perl-libwww-perl-5.79-6

Actual results:
--- snipp ---
--- perl-libwww-perl.spec       2004-11-25 21:38:50.000000000 +0100
+++ perl-libwww-perl.spec.rsc   2005-03-05 00:25:43.000000000 +0100
@@ -2,14 +2,14 @@

 Summary: A Perl interface to the World-Wide Web.
 Name: perl-libwww-perl
-Version: 5.79
-Release: 6
+Version: 5.803
+Release: 1
 License: GPL or Artistic
 Group: Applications/CPAN
-Source0: libwww-perl-%{version}.tar.gz
+Source0: http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-%{version}.tar.gz
 Source10: filter-depends.sh
 URL: http://search.cpan.org/dist/libwww-perl/
-BuildRoot: %{_tmppath}/perl-libwww-perl-buildroot/
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: perl >= 0:5.00503
 Requires: perl >= 0:5.00503
 Requires: perl(URI) perl(Digest::MD5)
@@ -67,16 +67,25 @@
 %files -f libwww-perl-%{version}-filelist
 %defattr(-,root,root)
 %doc AUTHORS Changes README*
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/LWP
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/Net
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/WWW
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/WWW/RobotRules
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/File
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/HTML
-%dir /usr/lib/perl5/vendor_perl/%(perl -MConfig -e 'print $Config{version}')/HTTP
-
+%dir %{perl_vendorlib}/Bundle
+%dir %{perl_vendorlib}/LWP
+%dir %{perl_vendorlib}/LWP/Authen
+%dir %{perl_vendorlib}/LWP/Protocol
+%dir %{perl_vendorlib}/Net
+%dir %{perl_vendorlib}/Net/HTTP
+%dir %{perl_vendorlib}/WWW
+%dir %{perl_vendorlib}/WWW/RobotRules
+%dir %{perl_vendorlib}/File
+%dir %{perl_vendorlib}/HTML
+%dir %{perl_vendorlib}/HTTP
+%dir %{perl_vendorlib}/HTTP/Cookies
+%dir %{perl_vendorlib}/HTTP/Headers
+%dir %{perl_vendorlib}/HTTP/Request

 %changelog
+* Sat Mar 05 2005 Robert Scheck <redhat@linuxnetz.de> 5.803-1
+- Upgrade to 5.803
+
 * Thu Nov 25 2004 Miloslav Trmac <mitr@redhat.com> - 5.79-6
 - Convert man page to UTF-8

--- snapp ---

Expected results:
Upgrade to 5.803 ;-)
Comment 1 Robert Scheck 2005-04-02 09:46:30 EST
Created attachment 112619 [details]
Diff between Core CVS and spec file closer to the template

- No %check, because other packages would be needed, which are not in Core
- Use of "chmod +x" to avoid problems like in bug #153186 comment #10
Comment 2 Warren Togami 2005-04-02 18:45:21 EST
I am wary of the need to chmod +x.  Further reviews please.
Comment 3 Jose Pedro Oliveira 2005-04-02 22:16:54 EST
Created attachment 112633 [details]
Update and specfile cleanup

Warren,

Patch summary:
* perl(URI) is a BuildRequirement
* patched Makefile.PL to add the aliases (HEAD, GET, ...)
* make test works (FC3)
* removed perl 5.8.x core modules from BuildRequires (MIME::Base64)
* removed perl 5.8.x core modules from Requires:
* added perl(Compress::Zlib) to the requirements list

/jpo
Comment 4 Warren Togami 2005-04-02 22:45:49 EST
+ make test
/usr/bin/perl t/TEST 0
base/common-req.......ok
base/cookies..........ok
base/date.............ok
base/headers-auth.....ok
base/headers-etag.....ok
base/headers-util.....ok
base/headers..........ok
base/http.............ok
base/listing..........ok
base/mediatypes.......ok
base/message-old......ok
base/message-parts....ok
base/message..........# Test 83 got: <UNDEF> (base/message.t at line 322)
#    Expected: "\x{FEFF}Hi there \x{263A}\n"
#  base/message.t line 322 is:      sub { eval { $m->decoded_content } },
"\x{FEFF}Hi there \x{263A}\n");
# Test 86 got: <UNDEF> (base/message.t at line 331)
#    Expected: "\x{FEFF}Hi there \x{263A}\n"
#  base/message.t line 331 is:      sub { eval { $m->decoded_content } },
"\x{FEFF}Hi there \x{263A}\n");
FAILED tests 83, 86
        Failed 2/92 tests, 97.83% okay
base/negotiate........ok
base/protocols........ok
base/response.........ok
base/status...........ok
base/ua...............ok
html/form-param.......ok
html/form.............ok
robot/rules-dbm.......ok
robot/rules...........ok
robot/ua-get..........ok
robot/ua..............ok
local/autoload-get....ok
local/autoload........ok
local/get.............ok
local/http-get........ok
local/http............ok
local/protosub........ok
Failed 1/30 test scripts, 96.67% okay. 2/759 subtests failed, 99.74% okay.
Failed Test    Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
base/message.t               92    2   2.17%  83 86
make: *** [test] Error 255
error: Bad exit status from
/usr/src/build/549978-noarch/install-tmp/rpm-tmp.93695 (%check)
Comment 5 Warren Togami 2005-04-02 22:54:56 EST
Another weird case where the tests go fine on my x86_64 FC4 everything install,
but not beehive...
Comment 6 Ville Skyttä 2005-04-03 07:08:34 EDT
The dep filtering solution applied here suffers from the same problem of not
honoring the system rpmbuild config as described elsewhere.  See perl-IPC-Run in
Extras/devel for an alternative approach.
http://cvs.fedora.redhat.com/viewcvs/devel/perl-IPC-Run/perl-IPC-Run.spec?root=extras&rev=.&view=auto
Comment 7 Warren Togami 2005-04-03 07:42:08 EDT
keeping bug open for a new patch
Comment 8 Robert Scheck 2005-04-15 15:17:59 EDT
Original issue of this report is solved with 5.803-2 in Rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.