Bug 150377 - system-config-printer hangs when new button is selected
system-config-printer hangs when new button is selected
Status: CLOSED DUPLICATE of bug 141430
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 23:55 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 12:26:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-04 23:55:33 EST
Description of problem:system-config-printer hangs when new button
is clicked


Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.1.1-1.x86_64.rpm
system-config-printer-gui-0.6.116.1.1-1.x86_64.rpm
How reproducible:


Steps to Reproduce:
1. start system-config-printer-gui
2. click new
3.
  
Actual results:
[root@localhost ~]# system-config-printer-gui
*** glibc detected *** malloc(): memory corruption: 0x0000000000525020 ***
sh: line 1: 14008 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 580, in
new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid
    self.populate_device_view ()
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1278, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1405, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment

Expected results:


Additional info:
Comment 1 Tim Waugh 2005-03-07 12:26:37 EST

*** This bug has been marked as a duplicate of 141430 ***

Note You need to log in before you can comment on or make changes to this bug.