Bug 150411 - mhash-devel does not require mhash
Summary: mhash-devel does not require mhash
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mhash (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-05 21:01 UTC by Leonard den Ottolander
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-05 21:09:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file with "mhash-devel Requires: mhash" removed. (2.35 KB, text/plain)
2005-03-05 21:03 UTC, Leonard den Ottolander
no flags Details

Description Leonard den Ottolander 2005-03-05 21:01:32 UTC
The requirement on mhash for mhash-devel is unnecessary.

Hence the Requires: mhash for mhash-devel can be removed.

Comment 1 Leonard den Ottolander 2005-03-05 21:03:14 UTC
Created attachment 111697 [details]
SPEC file with "mhash-devel Requires: mhash" removed.

Comment 2 Michael Schwendt 2005-03-05 21:09:31 UTC
Why? mhash-devel contains a symlink to a DSO file which is only
included in the main mhash package. Further, -devel package and main
package ought to be always in sync.


Comment 3 Leonard den Ottolander 2005-03-06 01:24:01 UTC
Nope. I can perfectly well build php with mhash support with only
mhash-devel installed. Only on the production machine (web server) I
will need to have mhash itself installed.

If every -devel package would need the main package to be installed
most build systems would grow rather fat, don't you think?

The shared object itself is not necessary to build binaries that
depend on it. Only the header file and the static library (.a and .la)
need to be available in the -devel package. The .so file can be safely
put in the main package without breaking anything.


Comment 4 Leonard den Ottolander 2005-03-06 01:34:48 UTC
Why do you exclude .la?

Comment 5 Leonard den Ottolander 2005-03-06 01:52:04 UTC
# libmhash.la - a libtool library file
# Generated by ltmain.sh - GNU libtool 1.5.10 (1.1220.2.130 2004/09/19
12:13:49)
#
# Please DO NOT delete this file!
# It is necessary for linking the library.


Comment 6 Michael Schwendt 2005-03-06 02:06:38 UTC
You can only build php like that, because the static archive for mhash
is included as well and you link statically. If it were not included,
your build would fail.

The .so link is not used at run-time, so it would be wrong to put it
into the main package. It's only used during build-time linking.
Including it within the main package would prevent multiple APIs/ABIs
of a library to be installable at once.

Take a look at other -devel packages. Find the rare exceptions where a
-devel package does not require its main package.

I exclude libtool archives, because we don't need them. Other issues
with .la files are not relevant for mhash.



Note You need to log in before you can comment on or make changes to this bug.