Bug 150455 - can not re-create a user account after deletion
can not re-create a user account after deletion
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-06 23:16 EST by andrew
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 10:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew 2005-03-06 23:16:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
Suppose the graphical interface for "Users and Groups" is used to
delete a users account (and home directory). Now create a new user
account with the same name as that just deleted. 

Try logging in to the re-created account and you will find that the 
gnome desktop does not start -- just get lots of error messages and
then the machine hangs (power-off was the only recovery I could find).

The problem is that old lock-files are left in /temp that should 
have been deleted when the users account was deleted.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. as above.
2.
3.
    

Additional info:


The problem is that old lock-files are left in /temp that should 
have been deleted when the users account was deleted.
Comment 1 Nils Philippsen 2005-03-07 02:58:55 EST
What's your exact version of system-config-users ("rpm -q system-config-users")?
Comment 2 Brian O Smith 2005-12-01 12:13:12 EST
I see the same with system-config-users-1.2.41-0.fc4.1.  Offending files & dirs are:

/tmp/mapping-<user>
/tmp/gconfd-<user>
/tmp/orbit-<user>
/tmp/xses-<user>.*
Comment 3 Nils Philippsen 2006-06-07 10:01:28 EDT
I couldn't reproduce your problem with system-config-users-1.2.42 following this
procedure:

1. create user test1 in s-c-users
2. login as test1 on second X server
3. logout test1
4. delete test1 in s-c-users
5. add user test in s-c-users (to ensure different user id for test1)
6. add user test1 in s-c-users
7. login as test1 on second X server

This worked for me as expected, as step 4. didn't leave around any files owned
by test1 in /tmp.

Note You need to log in before you can comment on or make changes to this bug.