Bug 150459 - Logwatch does not recognize sgi_fam message
Logwatch does not recognize sgi_fam message
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logwatch (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
RHEL3U7NAK
:
Depends On:
Blocks: 170445
  Show dependency treegraph
 
Reported: 2005-03-07 04:46 EST by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 21:02:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch. (607 bytes, patch)
2005-09-05 06:42 EDT, Ivana Varekova
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2005-03-07 04:46:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
This version of logwatch do not recognize messages of sgi_fam

Version-Release number of selected component (if applicable):
logwatch-4.3.2-2

How reproducible:
Always

Steps to Reproduce:
1. Install a program which uses fam
2. See logwatch output next day

  

Actual Results:   --------------------- Connections (secure-log) Begin ------------------------ 

**Unmatched Entries**
xinetd[9028]: START: sgi_fam pid=23057 from=<no address>
xinetd[9028]: START: sgi_fam pid=26338 from=<no address>
xinetd[9028]: START: sgi_fam pid=32302 from=<no address>
xinetd[9940]: START: sgi_fam pid=11961 from=<no address>
xinetd[9958]: START: sgi_fam pid=10551 from=<no address>
xinetd[9958]: START: sgi_fam pid=18655 from=<no address>
xinetd[9958]: START: sgi_fam pid=4607 from=<no address>
xinetd[9958]: START: sgi_fam pid=6205 from=<no address>
xinetd[9958]: START: sgi_fam pid=10700 from=<no address>
xinetd[9958]: START: sgi_fam pid=10918 from=<no address>
xinetd[9958]: START: sgi_fam pid=11015 from=<no address>

 ---------------------- Connections (secure-log) End ------------------------- 


Expected Results:  No such "unmached entries", because this are valid entries.

Additional info:
Comment 1 Ivana Varekova 2005-09-02 09:07:28 EDT
Can you please attach your /var/log/secure.? file containing sgi_fam log
messages (or part of that containing these messages).
Comment 2 Peter Bieringer 2005-09-02 09:14:02 EDT
Jun 14 20:57:34 host xinetd[12229]: START: sgi_fam pid=27865 from=<no address>
Jun 14 21:47:56 host xinetd[12229]: START: sgi_fam pid=29684 from=<no address>
Jun 15 05:34:33 host xinetd[12229]: START: sgi_fam pid=19790 from=<no address>
Jun 16 00:12:56 host xinetd[12229]: START: sgi_fam pid=29987 from=<no address>
Jun 16 07:51:43 host xinetd[12229]: START: sgi_fam pid=18451 from=<no address>
Comment 3 Ivana Varekova 2005-09-05 06:42:28 EDT
Created attachment 118455 [details]
Proposed patch.

Hello, 
thank you for your help. Attached patch should fix this problem. Could you test
it?
Comment 4 Peter Bieringer 2005-09-05 07:02:39 EDT
I already tested it since March by updating to logwatch-6.0.1 (where your patch
is included), it's working proper since then:

  Service sgi_fam [Connection(s) per day]:
       <no address>: 3 Time(s)
       Total Connections: 3

Note You need to log in before you can comment on or make changes to this bug.