This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 150460 - authd-rpm do not reload xinetd on deinstallation
authd-rpm do not reload xinetd on deinstallation
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: authd (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 04:54 EST by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 05:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-03-07 04:54:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
After deinstallation of package authd, xinetd got no reload

Version-Release number of selected component (if applicable):
authd-1.4.1-1.rhel3

How reproducible:
Always

Steps to Reproduce:
1. install RHEL3U4
2. reboot
3. netstat -nltpu
4. rpm -e authd
5. netstat -nlptu
  

Actual Results:  xinetd still keeps the port open

Expected Results:  xinetd get a reload on deinstallation of authd

Workaround: manual reload after deinstallation
# service xinetd reload

Additional info:

# rpm -qp --scripts /home/install-tmp/rhel3u4/RedHat/RPMS/authd-1.4.1-1.rhel3.i386.rpm
postinstall scriptlet (using /bin/sh):
/usr/sbin/adduser -s /sbin/nologin -r ident 2>/dev/null || true
/usr/bin/openssl rand -base64 -out /etc/ident.key 32
echo CHANGE THE LINE ABOVE TO A PASSPHRASE >> /etc/ident.key
/bin/chown ident:ident /etc/ident.key
chmod o-rw /etc/ident.key

%postuninstall is completly missing
Comment 1 Peter Bieringer 2005-03-09 06:08:25 EST
Ok, but as I see now on my system, user and group "ident" are still exists.
Probably this have to be deleted also?

BTW: it's strange but since ident is installed, I got a uid/gid mismatch for new
users:

nobody:x:99:
users:x:100:
ident:x:101:
amavis:x:102:
clamav:x:103:

nobody:x:99:99:Nobody:/:/sbin/nologin
ident:x:100:101::/home/ident:/sbin/nologin
amavis:x:101:102:Amavis email scan user:/var/amavis:/bin/sh
clamav:x:102:103:Clam Anti Virus Checker:/var/clamav:/sbin/nologin

Looks like "adduser" should be more smart try first uid=gid for machine accounts
and take very care using uid=100 automagically.
Comment 2 Martin Stransky 2005-04-08 06:14:14 EDT
About ident, we don't delete users, but only add them.
About guid/uid, in news release is /usr/sbin/adduser -u 98 which sort out this
issue.

Note You need to log in before you can comment on or make changes to this bug.