Bug 150469 - system treats free space for iriver ihp120 wrongly
system treats free space for iriver ihp120 wrongly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 09:02 EST by Ivan Sedo
Modified: 2015-01-04 17:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 01:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Sedo 2005-03-07 09:02:29 EST
Description of problem:
system treats free space for iriver ihp120 wrongly ..,
df yields
/dev/sdb1             19507904  19179512    328392  99% /media/IHP-100
where there is at least 3GB free (windows displays it correctly)
and it won't permitt to store more data that it thinks is free :(

dmesg output related to that device ...

usb 1-7: new high speed USB device using ehci_hcd and address 13
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 13
usb-storage: waiting for device to settle before scanning
  Vendor: TOSHIBA   Model: MK2004GAL         Rev: JC10
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 39063024 512-byte hdwr sectors (20000 MB)
sdb: assuming drive cache: write through
SCSI device sdb: 39063024 512-byte hdwr sectors (20000 MB)
sdb: assuming drive cache: write through
 sdb: sdb1
Attached scsi disk sdb at scsi5, channel 0, id 0, lun 0
usb-storage: device scan complete
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will
be case sensitive!
usb 1-7: USB disconnect, address 13



Version-Release number of selected component (if applicable):
kernel 2.6.10-1.766_FC3

How reproducible:
always

Steps to Reproduce:
1. plug the device in
2. execute df command
3. try to save more than df says it is free
  
Actual results:
system limits usage of the device in the way of determination of free space wrongly

Expected results:
system should determine free space correctly

Additional info:
Comment 1 Jeff Cheng 2005-04-10 22:40:38 EDT
I also have this problem, but with an external usb hard drive.  I have a seagate
160GB usb hard drive with ~90GB of data on it, but df reports only 12GB used
(148GB free).

From dmesg:
usb-storage: device scan complete
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
sda: assuming drive cache: write through
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
sda: assuming drive cache: write through
 sda: sda1
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Comment 2 Dave Jones 2005-07-15 14:36:49 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Ivan Sedo 2005-09-09 11:53:58 EDT
it works fine now, thanks :)
Comment 4 Fedora Update System 2014-10-08 15:40:04 EDT
scalapack-2.0.2-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/scalapack-2.0.2-5.el7

Note You need to log in before you can comment on or make changes to this bug.