Bug 150497 - sym53c8xx modules load when told not to
sym53c8xx modules load when told not to
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 14:17 EST by Jason
Modified: 2014-03-16 22:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 18:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-03-07 14:17:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
When my system starts (HP Netserver LC2000) the old megaraid driver is loaded but the sym53c8xx module is also loaded.  It is true that there is a sym538xx card in the server, but there is nothing attached to it.  I have looked in the BIOS and there is no way to disable the card.  I went into the scsi card bios and set its status to off, but still the module loads.  I deleted the alias scsi_hostadater1 sym53c8xx line from the modprobe.conf file in /etc, but the module still loads.  What is causing sym53c8xx to keep loading?  The goal is speedup boot time but not loading or starting extra items.

Version-Release number of selected component (if applicable):
2.6.10-1.770 and 2.6.10-1.766

How reproducible:
Always

Steps to Reproduce:
1. install FC2 or FC3
2. watch as the sym53c8xx module gets loaded
3.
  

Actual Results:  the module loads

Expected Results:  the module should not load

Additional info:
Comment 1 Dave Jones 2005-07-15 14:08:31 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Jason 2005-07-15 15:57:51 EDT
still in FC4
Comment 3 Dave Jones 2005-07-15 17:42:59 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 Jason 2005-07-18 10:21:24 EDT
still in 2.6.12-1.1398_FC4

Here is my modprobe.conf:
alias eth0 e1000
alias eth1 e100
alias scsi_hostadapter megaraid

Here is my hwconf:
-
class: OTHER
bus: PCI
detached: 0
driver: i2c-piix4
desc: "Broadcom (formerly ServerWorks) OSB4 South Bridge"
vendorId: 1166
deviceId: 0200
subVendorId: 1166
subDeviceId: 0200
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  f
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: shpchp
desc: "Intel Corporation 80960RP [i960 RP Microprocessor/Bridge]"
vendorId: 8086
deviceId: 0960
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  2
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Broadcom (formerly ServerWorks) CNB20LE Host Bridge"
vendorId: 1166
deviceId: 0009
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  0
pcifn:  1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Broadcom (formerly ServerWorks) CNB20LE Host Bridge"
vendorId: 1166
deviceId: 0009
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  0
pcifn:  0
-
class: OTHER
bus: SCSI
detached: 0
device: sg1
driver: ignore
desc: "Hp SAFTE; U160/M BP"
host: 0
id: 5
channel: 4
lun: 0
generic: sg1
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e1000
desc: "Intel Corporation 82543GC Gigabit Ethernet Controller (Fiber)"
network.hwaddr: 00:03:47:42:1C:81
vendorId: 8086
deviceId: 1001
subVendorId: 8086
subDeviceId: 1003
pciType: 1
pcidom:    0
pcibus:  3
pcidev:  5
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: e100
desc: "Intel Corporation 82557/8/9 [Ethernet Pro 100]"
network.hwaddr: 00:10:83:FD:01:A7
vendorId: 8086
deviceId: 1229
subVendorId: 103c
subDeviceId: 10ca
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  4
pcifn:  0
-
class: SCSI
bus: PCI
detached: 0
driver: sym53c8xx
desc: "LSI Logic / Symbios Logic 53C896/897"
vendorId: 1000
deviceId: 000b
subVendorId: 103c
subDeviceId: 60f0
pciType: 1
pcidom:    0
pcibus:  3
pcidev:  6
pcifn:  1
-
class: SCSI
bus: PCI
detached: 0
driver: sym53c8xx
desc: "LSI Logic / Symbios Logic 53C896/897"
vendorId: 1000
deviceId: 000b
subVendorId: 103c
subDeviceId: 60f0
pciType: 1
pcidom:    0
pcibus:  3
pcidev:  6
pcifn:  0
-
class: SCSI
bus: PCI
detached: 0
driver: megaraid
desc: "Intel Corporation 80960RP [i960RP Microprocessor]"
vendorId: 8086
deviceId: 1960
subVendorId: 103c
subDeviceId: 10cd
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  2
pcifn:  1
-
class: CDROM
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "HITACHI CDR-8435"
-
class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Mach64 3D Rage IIC
desc: "ATI Technologies Inc 3D Rage IIC"
vendorId: 1002
deviceId: 4759
subVendorId: 103c
subDeviceId: 10c4
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  5
pcifn:  0
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "ATI Technologies Inc. MACH64GT"
mem: 2048
-
class: FLOPPY
bus: MISC
detached: 0
device: fd0
driver: unknown
desc: "3.5" 1.44MB floppy drive"
-
class: HD
bus: SCSI
detached: 0
device: sda
driver: ignore
desc: "Megaraid LD0 RAID1  8677R"
host: 0
id: 0
channel: 0
lun: 0
generic: sg0
-
class: KEYBOARD
bus: PSAUX
detached: 0
driver: ignore
desc: "AT Raw Set 2 keyboard"
-
class: KEYBOARD
bus: PSAUX
detached: 0
driver: ignore
desc: "AT Translated Set 2 keyboard"
-
class: KEYBOARD
bus: KEYBOARD
detached: 0
device: ttyS0
driver: ignore
desc: "Serial console (57600 baud) ttyS0"
-
class: IDE
bus: PCI
detached: 0
driver: unknown
desc: "Broadcom (formerly ServerWorks) OSB4 IDE Controller"
vendorId: 1166
deviceId: 0211
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  f
pcifn:  1

Here are the messages:
Jul 18 09:05:34 cisit6 kernel: megaraid: found 0x8086:0x1960:bus 0:slot 2:func 1
Jul 18 09:05:34 cisit6 kernel: scsi0:Found MegaRAID controller at 0xf8804000,
IRQ:177
Jul 18 09:05:34 cisit6 kernel: megaraid: [      F :B ] detected 1 logical drives.
Jul 18 09:05:34 cisit6 kernel: megaraid: channel[0] is raid.
Jul 18 09:05:34 cisit6 kernel: scsi0 : LSI Logic MegaRAID       F  254 commands
16 targs 4 chans 7 luns
Jul 18 09:05:34 cisit6 kernel: scsi0: scanning scsi channel 0 for logical drives.
Jul 18 09:05:34 cisit6 kernel:   Vendor: MegaRAID  Model: LD0 RAID1  8677R  Rev:   F
Jul 18 09:05:34 cisit6 kernel:   Type:   Direct-Access                      ANSI
SCSI revision: 02
Jul 18 09:05:34 cisit6 kernel: SCSI device sda: 17770496 512-byte hdwr sectors
(9098 MB)
Jul 18 09:05:34 cisit6 kernel: sda: asking for cache data failed
Jul 18 09:05:34 cisit6 kernel: sda: assuming drive cache: write through
Jul 18 09:05:35 cisit6 kernel: SCSI device sda: 17770496 512-byte hdwr sectors
(9098 MB)
Jul 18 09:05:35 cisit6 kernel: sda: asking for cache data failed
Jul 18 09:05:35 cisit6 kernel: sda: assuming drive cache: write through
Jul 18 09:05:35 cisit6 kernel:  sda: sda1 sda2
Jul 18 09:05:35 cisit6 kernel: Attached scsi disk sda at scsi0, channel 0, id 0,
lun 0
Jul 18 09:05:35 cisit6 kernel: scsi0: scanning scsi channel 4 [P0] for physical
devices.
Jul 18 09:05:35 cisit6 kernel:   Vendor: HP        Model: SAFTE; U160/M BP  Rev:
1023
Jul 18 09:05:35 cisit6 kernel:   Type:   Processor                          ANSI
SCSI revision: 02

Jul 18 09:05:36 cisit6 kernel: sym0: <896> rev 0x6 at pci 0000:03:06.0 irq 185
Jul 18 09:05:36 cisit6 kernel: sym0: Symbios NVRAM, ID 7, Fast-40, LVD, parity
checking
Jul 18 09:05:36 cisit6 kernel: sym0: open drain IRQ line driver
Jul 18 09:05:36 cisit6 kernel: sym0: using LOAD/STORE-based firmware.
Jul 18 09:05:36 cisit6 kernel: sym0: handling phase mismatch from SCRIPTS.
Jul 18 09:05:36 cisit6 kernel: sym0: SCSI BUS has been reset.
Jul 18 09:05:36 cisit6 kernel: scsi1 : sym-2.2.0
Jul 18 09:05:36 cisit6 kernel: ACPI: PCI Interrupt 0000:03:06.1[B] -> GSI 25
(level, low) -> IRQ 193
Jul 18 09:05:36 cisit6 kernel: sym1: <896> rev 0x6 at pci 0000:03:06.1 irq 193
Jul 18 09:05:36 cisit6 kernel: sym1: Symbios NVRAM, ID 7, Fast-40, SE, parity
checking
Jul 18 09:05:36 cisit6 kernel: sym1: open drain IRQ line driver
Jul 18 09:05:36 cisit6 kernel: sym1: using LOAD/STORE-based firmware.
Jul 18 09:05:36 cisit6 kernel: sym1: handling phase mismatch from SCRIPTS.
Jul 18 09:05:36 cisit6 kernel: sym1: SCSI BUS has been reset.
Jul 18 09:05:36 cisit6 kernel: scsi2 : sym-2.2.0
Jul 18 09:05:36 cisit6 kernel: sym1: SCSI BUS mode change from SE to SE.
Jul 18 09:05:36 cisit6 kernel: sym1: SCSI BUS has been reset.

If you need anything else please let me know.

Jason
Comment 5 Dave Jones 2005-08-04 01:46:31 EDT
if you remove the alias scsi_hostadater1 sym53c8xx line from modprobe.conf amd
then recreate the initrd (run mkinitrd with no args for an example), the driver
shouldn't be added to the initrd, and on the next boot it should go away.

However, if kudzu runs for whatever reason, it may put it back.
You could chkconfig kudzu off to stop that happening.


You can also double check that it isnt in the initrd by doing something like this..


cp /boot/initrd-2.6.12-1.1446_FC5.img initrd.cpio.gz
gzip -d initrd.cpio.gz

(you can now browse the initrd.cpio archive with 'mc', or use standard cpio
tools on it) Look in the lib/ subdir to see what modules are present.

Comment 6 Jason 2005-08-04 09:56:25 EDT
I exploded the initrd-2.6.12-1.1398_FC4smp file and only the following are in
lib directory:
dm-mirror.ko  dm-snapshot.ko  ext3.ko  megaraid.ko  sd_mod.ko
dm-mod.ko     dm-zero.ko      jbd.ko   scsi_mod.ko

Everytime I boot I see the following in dmesg:
ACPI: PCI Interrupt 0000:03:06.0[A] -> GSI 24 (level, low) -> IRQ 185
sym0: <896> rev 0x6 at pci 0000:03:06.0 irq 185
sym0: Symbios NVRAM, ID 7, Fast-40, LVD, parity checking
sym0: open drain IRQ line driver
sym0: using LOAD/STORE-based firmware.
sym0: handling phase mismatch from SCRIPTS.
sym0: SCSI BUS has been reset.
scsi1 : sym-2.2.0
ACPI: PCI Interrupt 0000:03:06.1[B] -> GSI 25 (level, low) -> IRQ 193
sym1: <896> rev 0x6 at pci 0000:03:06.1 irq 193
sym1: Symbios NVRAM, ID 7, Fast-40, SE, parity checking
sym1: open drain IRQ line driver
sym1: using LOAD/STORE-based firmware.
sym1: handling phase mismatch from SCRIPTS.
sym1: SCSI BUS has been reset.
scsi2 : sym-2.2.0
sym1: SCSI BUS mode change from SE to SE.
sym1: SCSI BUS has been reset.

My modprobe.conf looks like this:
alias eth0 e1000
alias eth1 e100
alias scsi_hostadapter megaraid

Since there is no driver in initrd for the sym scsi card how/why is it being
detected during boot?
Comment 7 Dave Jones 2005-08-04 13:37:27 EDT
hmm, does it get loaded later in the boot, once init scripts have started running? 
(When it does starting storage.. maybe ?)

ahhh. /etc/rc.d/rc.sysinit has a section where it parses the output of
/sbin/kmodule (part of initscripts).

Bill, what needs updating to stop this happening ? hwdata ?
Comment 8 Bill Nottingham 2005-08-04 13:58:22 EDT
Nothing needs *updated*; he has a sym53c8xx card, so the driver is loaded.

Adding 'install sym53c8xx /bin/true' to /etc/modprobe.conf should cause it to
not get loaded.
Comment 9 Jason 2005-08-08 10:07:47 EDT
I followed the instructions from comment 8 and the driver nolonger loads.  The
reason I don't want the driver to load is because I don't use that card.  I have
HP NetRaid 1Si card that use instead.  They way I figure it (and please correct
me if I am wrong) is if the driver loads, it is using resources.  It also slows
down the boot up of the machine by about 5 or 6 seconds, sometimes longer.  It
has to probe for non-existant hard drives and that takes time.  Saving seconds
on a system that takes about 2 minutes to boot is a good thing.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.