Bug 150556 - Unable to rpmbuild cdrtools 2.01.1-5 on rhel4
Unable to rpmbuild cdrtools 2.01.1-5 on rhel4
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cdrtools (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 06:27 EST by Andrei Maslennikov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 09:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cdrtools, log of rpmbuild --bb (129.96 KB, text/plain)
2005-03-08 06:27 EST, Andrei Maslennikov
no flags Details

  None (edit)
Description Andrei Maslennikov 2005-03-08 06:27:47 EST
Rpmbuild on RHEL4 fails as apparently there is a problem with 
at least cdda2wav:

RPM build errors:
    File not found: /var/tmp/cdrtools-2.01.1-root/usr/lib/libscg.a
    File not found: /var/tmp/cdrtools-2.01.1-root/usr/bin/cdda2wav
    File not found by glob:
/var/tmp/cdrtools-2.01.1-root/usr/share/man/man1/cdda2wav.1*

I attach the full build log. It looks like cdda2wav build fails due
to the make/smake issues:

make[1]: Entering directory
`/system/Builds/Usr.src.redhat/BUILD/cdrtools-2.01/cdda2wav'
../RULES/local.cnf:39: OBJ/i686-linux-cc/Inull: No such file or directory
../RULES/local.cnf:40: OBJ/i686-linux-cc/local.cnf: No such file or directory
../RULES/r-gmake.dep:76: OBJ/i686-linux-cc/cdda2wav.d: No such file or directory
../RULES/r-gmake.dep:76: OBJ/i686-linux-cc/interface.d: No such file or directory
../RULES/r-gmake.dep:76: OBJ/i686-linux-cc/semshm.d: No such file or directory
.......
In file included from base64.c:71:
config.h:35:21: lconfig.h: No such file or directory
        ==> MAKING DEPENDENCIES "OBJ/i686-linux-cc/sha_func.d"
In file included from sha_func.c:38:
config.h:35:21: lconfig.h: No such file or directory
        ==> MAKING DEPENDENCIES "OBJ/i686-linux-cc/ioctl.d"
In file included from ioctl.c:16:
config.h:35:21: lconfig.h: No such file or directory
.....
and so on and so far
Comment 1 Andrei Maslennikov 2005-03-08 06:27:47 EST
Created attachment 111774 [details]
cdrtools, log of rpmbuild --bb

Note You need to log in before you can comment on or make changes to this bug.