Bug 150563 - Fencing agent for Dell 1855 blade chassis DRAC/MC
Summary: Fencing agent for Dell 1855 blade chassis DRAC/MC
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam "mantis" Manthei
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-08 12:58 UTC by Andrew C. Dingman
Modified: 2009-04-16 19:56 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-723
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-10 15:25:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fencing agent for Dell 1855 blade DRAC/MC (6.06 KB, text/plain)
2005-03-08 12:58 UTC, Andrew C. Dingman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:723 normal SHIPPED_LIVE GFS bug fix update 2005-09-30 04:00:00 UTC

Description Andrew C. Dingman 2005-03-08 12:58:16 UTC
Description of problem:
Current release and CVS lack a fencing agent for Dell 1855 blade enclosures.


Steps to Reproduce:
1. Buy a bunch of 1855 blades.
2. Search for a fencing agent.
3. Discover that DRAC/MCs don't support 'racadm', and therefore don't work
   with fence_drac.
  
Actual results:
   Wrote my own. Here it is

Expected results:
   Now there's a fencing agent for Dell 1855 blades.

Additional info:
   Fence seems to expect some output on either STDOUT or STDERR that I'm not
producing, but this agent does work. If someone doesn't beat me to it, I'll post
 a fix for that problem in a week or two, when I have time.

Comment 1 Andrew C. Dingman 2005-03-08 12:58:16 UTC
Created attachment 111776 [details]
Fencing agent for Dell 1855 blade DRAC/MC

Comment 2 Adam "mantis" Manthei 2005-08-01 22:05:03 UTC
fence_drac now supports Dell PowerEdge 1855 firmware 1.1  (Build 03.03)

Comment 3 Adam "mantis" Manthei 2005-08-01 22:31:50 UTC
Comment on attachment 111776 [details]
Fencing agent for Dell 1855 blade DRAC/MC

This patch (attachment #111776 [details]) is risky because it doesn't wait to make sure
that the blade is ever powered off before returning a successful return code.

Comment 5 Red Hat Bugzilla 2005-09-30 14:55:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-723.html


Comment 6 Red Hat Bugzilla 2005-10-10 15:25:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-723.html



Note You need to log in before you can comment on or make changes to this bug.