Bug 150620 - autofs fails to load ldap maps
autofs fails to load ldap maps
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 17:34 EST by P Jones
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 17:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to /etc/init.d/autofs (455 bytes, patch)
2005-03-08 17:35 EST, P Jones
no flags Details | Diff
same patch, not filterd through bash. :( (487 bytes, patch)
2005-03-08 17:38 EST, P Jones
no flags Details | Diff
auto.master (325 bytes, text/plain)
2005-03-09 18:02 EST, P Jones
no flags Details

  None (edit)
Description P Jones 2005-03-08 17:34:07 EST
Description of problem:
autofs fails to load ldap maps.  it erronously adds yp to the string
in the init script


Version-Release number of selected component (if applicable):
autofs-4.1.3-28 and autofs-4.1.3-99 both have this

How reproducible:
always, as easy as setting up a ldap server

Steps to Reproduce:
1. create ldap server
2.  add autofs maps
3.  restart autofs
  
Actual results:
init script calls "/usr/sbin/automount --timeout=60 /data yp ldap
blip.internal.datastacks.com:ou=auto.data,dc=dsmouse,dc=net
" which is obvously bunk.   gets this message in log:
Mar  8 17:10:38 localhost automount[10216]: lookup(yp): map ldap:
Local domain name not set



Expected results:
it to actually mount at the right place :)

Additional info:
patch to fix it attached
Comment 1 P Jones 2005-03-08 17:35:53 EST
Created attachment 111795 [details]
patch to /etc/init.d/autofs 

this is a patch to autofs-4.1.3-28; -99 works too, but line numbers change.
Comment 2 P Jones 2005-03-08 17:38:38 EST
Created attachment 111796 [details]
same patch, not filterd through bash. :(
Comment 3 Chris Feist 2005-03-09 16:40:31 EST
Could you post your /etc/auto.master (or auto_master) file?
Comment 4 P Jones 2005-03-09 18:02:41 EST
Created attachment 111828 [details]
auto.master
Comment 5 P Jones 2005-03-09 18:03:54 EST
all the autofs files are unmodified from the rpm. The only way autofs
knows to use ldap is the "automount:  files ldap" in nsswitch.conf (as
generated by authconfig)
Comment 6 Chris Feist 2005-03-10 10:35:51 EST
Can you post the results from the following command:

/usr/lib/autofs/autofs-ldap-auto-master
Comment 7 P Jones 2005-03-10 11:36:24 EST
/data ldap blip.internal.datastacks.com:ou=auto.data,dc=dsmouse,dc=net
Comment 8 Chris Feist 2005-03-10 11:47:37 EST
Thanks,

Can you post the maps that you loaded into ldap?

Could you also post the output from the following command:
ldapsearch -x -b 'ou=auto.master,dc=dsmouse,dc=net'
Comment 9 P Jones 2005-03-10 14:33:46 EST
[root@localhost ~]# ldapsearch -x -b 'ou=auto.master,dc=dsmouse,dc=net'
# extended LDIF
#
# LDAPv3
# base <ou=auto.master,dc=dsmouse,dc=net> with scope sub
# filter: (objectclass=*)
# requesting: ALL
#

# auto.master, dsmouse.net
dn: ou=auto.master,dc=dsmouse,dc=net
ou: auto.master
objectClass: top
objectClass: automountMap

# /data, auto.master, dsmouse.net
dn: cn=/data,ou=auto.master,dc=dsmouse,dc=net
objectClass: automount
automountInformation: ldap
blip.internal.datastacks.com:ou=auto.data,dc=dsmous
 e,dc=net
cn: /data

# search result
search: 2
result: 0 Success

# numResponses: 3
# numEntries: 2


Comment 10 P Jones 2005-03-10 14:34:20 EST
also, because you're going to ask for this next:
]# ldapsearch -x -b 'ou=auto.data,dc=dsmouse,dc=net'
# extended LDIF
#
# LDAPv3
# base <ou=auto.data,dc=dsmouse,dc=net> with scope sub
# filter: (objectclass=*)
# requesting: ALL
#

# auto.data, dsmouse.net
dn: ou=auto.data,dc=dsmouse,dc=net
ou: auto.data
objectClass: top
objectClass: automountMap

# home, auto.data, dsmouse.net
dn: cn=home,ou=auto.data,dc=dsmouse,dc=net
objectClass: automount
automountInformation: -fstype=nfs,hard,intr,nodev,nosuid
starfish:/ldata/home
cn: home
Comment 11 Chris Feist 2005-03-10 14:48:56 EST
Ok, so the problem you're having is caused because you've got a slight
error in your auto.master ldap map.

Your automountInformation line reads like this:
automountInformation: ldap
blip.internal.datastacks.com:ou=auto.data,dc=dsmouse,dc=net

It should read like this:
ldap://blip.internal.datastacks.com:ou=auto.data,dc=dsmouse,dc=net

You can use the /usr/share/doc/autofs-4.1.3/ldap-automount-auto.master
file for reference.

Can you make that change and let me know if everything works?
Comment 12 P Jones 2005-03-10 16:12:43 EST
That didn't work, but ldap:blip.... did... 

I added a extra "getmounts" on line 474 to see what it was doing, and
it was trying "/usr/sbin/automount --timeout=60 /data ldap
//blip.internal.datastacks.com:ou=auto.data,dc=dsmouse,dc=net"

I removed the // to get it to work...  
Comment 13 Chris Feist 2005-03-14 11:19:10 EST
What error do you get when you include the "//".  This *should* work.
 Can you also try using autofs-4.1.3-107?  This is the latest FC autofs.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/autofs-4.1.3-107.i386.rpm
Comment 14 Chris Feist 2005-05-31 17:49:07 EDT
No response recieved, closing as WORKSFORME.  Please re-open this bug if the
problem persists.

Note You need to log in before you can comment on or make changes to this bug.