Bug 150646 - switching keyboard layout to English is not available
Summary: switching keyboard layout to English is not available
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-09 07:26 UTC by Andrew Martynov
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 15:06:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "ps ax" (3.12 KB, text/plain)
2005-05-04 11:54 UTC, Andrew Martynov
no flags Details
/etc/rhgb/temp/XFree86.0.log (35.29 KB, text/plain)
2005-05-04 11:56 UTC, Andrew Martynov
no flags Details
/etc/sysconfig/i18n (80 bytes, text/plain)
2005-05-04 11:56 UTC, Andrew Martynov
no flags Details
/etc/sysconfig/keyboard (32 bytes, text/plain)
2005-05-04 11:57 UTC, Andrew Martynov
no flags Details
/etc/X11/xorg.conf (2.82 KB, text/plain)
2005-05-04 11:59 UTC, Andrew Martynov
no flags Details

Description Andrew Martynov 2005-03-09 07:26:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

Description of problem:
Is system is installed with Russian system language Setup Agent starts with Russian keyboard layout and does not allow switch to English.

Version-Release number of selected component (if applicable):
firstboot-1.3.39-2

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 4 with Russian assystem language
2. Reboot into runlevel 5
3. Try to create user account with name in English 
  

Actual Results:  Keyboard layout can be switched between Russian and English 

Expected Results:  Keyboard layout cannot be switched from Russian to English 
using nor Shift+Shift or Ctrl_Shift or Alt+Shift

Additional info:

Comment 1 Leon Ho 2005-03-14 01:00:16 UTC
Look like it is a rhpl issue. Reassigning.

Comment 2 Paul Nasrat 2005-03-14 06:16:51 UTC
Hmm, can you attach /etc/sysconfig/i18n and /etc/sysconfig/keyboard.  Does the
toggle work in X after firstboot?

Comment 3 Andrew Martynov 2005-03-17 10:36:49 UTC
After first boot switching in X works normally.

I reinstall RHEL 4 for two boxes and inside of VMWare.
For now I cannot reproduce the probles. I will tomorrow reinstall the mashine
where I have got the problem and will attach necessary files if problem occures
again.

Comment 4 Andrew Martynov 2005-05-04 11:50:58 UTC
Sorry for long delay.

I investigate the problem and found a way how to reproduce the bug:
- Install RHEL4 ES on clean HDD in Russian locale
- Boot into system using default options:
   - rhgb enabled
   - default runlevel 5
- Try to switch from RU keyboard layout to US in Setup Agent,
  i.e. in user creation dialog.

My opinion: 
After first reboot rhgb starts, the boot text is displayed on graphic screen.
Setup Agent (firstboot) starts and try to reuse X server from rhgb.

Please look into attached log file from X server. You can find messages from XKB
extention and "ps ax" shown 5-10 frozen setxkbmap processes.

If rhgb is turned off via grub.conf or system booted into runlevel 3 and after
switched to runlevel 5 - the bug does not appears.

Comment 5 Andrew Martynov 2005-05-04 11:54:13 UTC
Created attachment 114001 [details]
output of "ps ax"

You can see frozzen processes setxkbmap when firstboot is running. This data
was taken via ssh connection to test box.

Comment 6 Andrew Martynov 2005-05-04 11:56:07 UTC
Created attachment 114002 [details]
/etc/rhgb/temp/XFree86.0.log

Log file from X server started by rhgb. This X server will be reused by
firstboot later. You can see some error messages from XKB extension.

Comment 7 Andrew Martynov 2005-05-04 11:56:57 UTC
Created attachment 114003 [details]
/etc/sysconfig/i18n

Comment 8 Andrew Martynov 2005-05-04 11:57:39 UTC
Created attachment 114004 [details]
/etc/sysconfig/keyboard

Comment 9 Andrew Martynov 2005-05-04 11:59:59 UTC
Created attachment 114005 [details]
/etc/X11/xorg.conf

This file contains correct description of keyboard layouts "us,ru", so keyboard
switching works well in standard X enviroment after Setup Agent finished and
GDM allows enter user name.

Comment 10 Andrew Martynov 2005-05-15 20:43:42 UTC
During testing of FC4-test3 this problem was reproduced.

If required I can attach necessary log and config files.

Comment 11 Chris Lumens 2005-11-03 15:06:22 UTC
The dead setxkb processes are suspicious, but totally unrelated.  This has been
fixed in Rawhide and will be in the next version of RHEL.  If you require a fix
in  an update of RHEL4, please go through Issue Tracker.


Note You need to log in before you can comment on or make changes to this bug.