Bug 150651 - missing function in dhclient_script
missing function in dhclient_script
Status: CLOSED DUPLICATE of bug 146817
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcpcd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Depends On:
  Show dependency treegraph
Reported: 2005-03-09 07:33 EST by Mark Baker
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-09 10:28:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Baker 2005-03-09 07:33:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
bringing up a network interface (i.e eth0) generates follwoing:

Determining IP information for eth0.../sbin/dhclient-script: line 52:
change_resolv_conf: command not found

Net result is that /etc/resolv.conf is not updated.

Not sure why I have only recently noticed this and pretty sure that it
will have been reported elsewhere but I can'tfind it so bugzilla it

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install dhclient-3.0.1-10_EL3
2.bring interface using "ifup <interface_name>"

Actual Results:  resolv.conf did not get updatedor created

Expected Results:  resolv.conf would get created or updated.

Additional info:
Comment 1 Jason Vas Dias 2005-03-09 10:28:19 EST
This problem shows you do not have the latest version of initscripts
for RHEL-3 installed : initscripts-7.31.18.EL .
Please ensure you have this package installed - if not, run up2date .
If RPM reports that it is installed, it may have created a 
file if you had modified the network-functions file from the previous
release - replace network-functions with network-functions.rpmnew in
this case. 
The network-functions script from initscripts-7.31.18.EL contains the
change_resolv_conf function that dhclient-script requires. 
Comment 2 Jason Vas Dias 2005-04-02 15:03:26 EST

*** This bug has been marked as a duplicate of 146817 ***

Note You need to log in before you can comment on or make changes to this bug.