Bug 150655 - RFE: a bugzilla query that returns 1 row, should take the user to a show_bug interface
RFE: a bugzilla query that returns 1 row, should take the user to a show_bug ...
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Kevin Baker
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 08:50 EST by James Laska
Modified: 2014-12-01 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 08:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-03-09 08:50:45 EST
I've seen this behavior in other tools before, thought perhaps it would make a
nice fit with bugzilla.  Perhaps could be a user configurable option to
[dis|en]able the feature.

For example, it would be handy if the following query which returns only 1 row:
 https://bugzilla.redhat.com/beta/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Fedora+Core&product=Red+Hat+Enterprise+Linux&product=Red+Hat+Enterprise+Linux+Beta&product=Red+Hat+Enterprise+Linux+Public+Beta&component_text=&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=NEEDINFO&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=QA_READY&bug_status=ON_QA&bug_status=PROD_READY&bug_status=FAILS_QA&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&fixed_in_type=allwordssubstr&fixed_in=&qa_whiteboard_type=allwordssubstr&qa_whiteboard=&devel_whiteboard_type=allwordssubstr&devel_whiteboard=&keywords_type=allwords&keywords=&cust_facing=&cust_facing_type=substring&emailreporter1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailcc2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=short_desc&type0-0-0=regexp&value0-0-0=ltc11894

Would take you to the show_bug interface for that 1 row:

https://bugzilla.redhat.com/beta/show_bug.cgi?id=136265

And display a note at the top of show_bug.cgi indicating that the only 1 row was
returned so that result has been displayed.

Thoughts?
Comment 1 David Lawrence 2008-09-16 12:52:10 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 2 David Lawrence 2010-01-15 12:32:44 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 3 David Lawrence 2010-08-25 17:41:04 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 5 Simon Green 2012-05-10 08:09:52 EDT
There are two reasons why this isn't a good idea.

1) If you want to save the search (and expect more than one bug to be returned in future), you won't be able to.
2) If you want to edit the search (because you expected more than one bug to be returned), you wouldn't be able to edit it.

  -- simon
Comment 6 James Laska 2012-05-10 09:01:10 EDT
(In reply to comment #5)
> There are two reasons why this isn't a good idea.
> 
> 1) If you want to save the search (and expect more than one bug to be returned
> in future), you won't be able to.
> 2) If you want to edit the search (because you expected more than one bug to be
> returned), you wouldn't be able to edit it.

Not sure I'd classify it as a "bad idea", but you certainly raise valid concerns.

Thanks for your consideration.  I'll track the upstream request instead with fingers crossed.

Note You need to log in before you can comment on or make changes to this bug.