Bug 150685 - RFE: add option to disable metacity's raise-on-click behavior
RFE: add option to disable metacity's raise-on-click behavior
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 12:42 EST by Aaron Gaudio
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple patch to disable raise-on-click when in mouse/sloppy focus (685 bytes, patch)
2005-03-20 12:09 EST, Aaron Gaudio
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 76672 None None None Never

  None (edit)
Description Aaron Gaudio 2005-03-09 12:42:20 EST
Description of problem:
I'm a relatively new metacity user (been using sawfish for a long time, and
before that...uh... fvwm). I like pointer focus, and I'm finding metacity's
raise-on-click behavior (raise a window whenever you click anywhere in it) quite
infuriating. I like to stack my windows, and still be able to click inside
lower-stacked windows without them popping to the front. 


Version-Release number of selected component (if applicable):
metacity-2.8.6-2

How reproducible:
Always

Steps to Reproduce:
1. Set your metacity focus mode to pointer focus.
2. Cascade some windows so that one is below the other and partially obscured by it.
3. Single-click (a simple press will suffice, actually) the window lower in the
stack.
  
Actual results:
The lower window is automatically raised.

Expected results:
There should be an option at least in gconf
(/apps/metacity/general/raise_on_click perhaps) to make it so that the lower
window would not be raised on the click.

Additional info:

I've looked at some of the discussions in old mailing lists and the upstream
gnome bugzilla (bug 76672) for this, and it looks like Havic and the gnome folks
are happy leaving this option out. However, I think there are many like myself
who would like to be able to disable this behavior, and I therefore request that
Fedora add this functionality to its build of metacity.

I've seen a suggested patch for this at
http://mail.gnome.org/archives/desktop-devel-list/2003-June/msg00482.html, so
I'm sure it's quite doable. If I have time, I might even try porting that to the
current metacity build.
Comment 1 Aaron Gaudio 2005-03-20 12:09:22 EST
Created attachment 112159 [details]
Simple patch to disable raise-on-click when in mouse/sloppy focus

I discovered that Havoc put in a conditional to control this behaviour and then
commented it out. I uncommented out. My vote is for raise on click to be
disabled by default when in mouse or sloppy focus mode, regardless of if there
is a gconf option to control this.
Comment 2 Ray Strode [halfline] 2005-03-23 09:52:54 EST
Hi,

For things of this nature, we like to stick to whatever upstream does.  Could
you re-file this bug upstream at bugzilla.gnome.org and post a comment here with
the URL to the upstream bug report?

Thanks.
Comment 3 Ray Strode [halfline] 2005-05-11 17:23:56 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.