Bug 150740 - avc: denied {..} for .. scontext=user_u:system_r:ifconfig_t tcontext=system_u:object_r:root_t tclass=file
avc: denied {..} for .. scontext=user_u:system_r:ifconfig_t tcontext=system...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 22:14 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: selinux-policy-targeted-1.23.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 11:06:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg in kernel-2.6.11-1.1177_FC4 (21.14 KB, text/plain)
2005-03-09 22:14 EST, sangu
no flags Details

  None (edit)
Description sangu 2005-03-09 22:14:57 EST
Description of problem:
in dmesg
[...]
audit(1110422282.990:0): avc:  denied  { read } for  pid=2098 exe=/sbin/ip
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422282.998:0): avc:  denied  { read } for  pid=2101 exe=/sbin/ip
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.010:0): avc:  denied  { read } for  pid=2104 exe=/sbin/ip
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.018:0): avc:  denied  { read } for  pid=2106 exe=/sbin/ethtool
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.097:0): avc:  denied  { read } for  pid=2116 exe=/sbin/ip
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.103:0): avc:  denied  { read } for  pid=2118 exe=/sbin/ip
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.114:0): avc:  denied  { read } for  pid=2120 exe=/sbin/mii-tool
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
audit(1110422283.124:0): avc:  denied  { read } for  pid=2126 exe=/sbin/ethtool
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t tcontext=system
[...]
audit(1110422288.535:0): avc:  denied  { read } for  pid=2301 exe=/sbin/ifconfig
path=/init dev=rootfs ino=32 scontext=user_u:system_r:ifconfig_t
tcontext=system_u:object_r:root_t tclass=file
[...]

------
Installing selinux-policy-targeted packages
$rpm -Uhv selinux-policy-targeted-*1.21.16-4*
준비 중...               ########################################### [100%]
   1:selinux-policy-targeted########################################### [ 50%]
   2:selinux-policy-targeted########################################### [100%]
/sbin/restorecon reset context
/bin/hostname:system_u:object_r:bin_t->system_u:object_r:hostname_exec_t
/sbin/restorecon reset context
/sbin/ethtool:system_u:object_r:sbin_t->system_u:object_r:ifconfig_exec_t
/sbin/restorecon reset context
/sbin/ifconfig:system_u:object_r:sbin_t->system_u:object_r:ifconfig_exec_t
/sbin/restorecon reset context
/sbin/ip:system_u:object_r:sbin_t->system_u:object_r:ifconfig_exec_t
/sbin/restorecon reset context
/sbin/mii-tool:system_u:object_r:sbin_t->system_u:object_r:ifconfig_exec_t
/sbin/restorecon reset context
/sbin/tc:system_u:object_r:sbin_t->system_u:object_r:ifconfig_exec_t

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.21.16-4

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2005-03-09 22:14:58 EST
Created attachment 111838 [details]
dmesg in kernel-2.6.11-1.1177_FC4
Comment 2 Daniel Walsh 2005-03-10 11:27:39 EST
These AVC messages are from prior to the udpate.  Are you seeing the
problem still?  Or are you getting an address with no knew errors.

Dan
Comment 3 sangu 2005-03-10 11:35:49 EST
After booting, this AVC messages always appear in dmesg. But using internet
works well.
Comment 4 Daniel Walsh 2005-03-10 12:08:10 EST
Then there is a problem in your labeling, since ifconfig and ip should be
labeled ifconfig_exec_t

ls -lZ /sbin/ifconfig /sbin/ip

ls -lZ /sbin/ifconfig  /sbin/ip
-rwxr-xr-x  root     root     system_u:object_r:ifconfig_exec_t /sbin/ifconfig
-rwxr-xr-x  root     root     system_u:object_r:ifconfig_exec_t /sbin/ip
Comment 5 sangu 2005-03-10 12:40:55 EST
In my linux box
 $ls -lZ /sbin/ifconfig /sbin/ip
-rwxr-xr-x  root     root     system_u:object_r:ifconfig_exec_t /sbin/ifconfig
-rwxr-xr-x  root     root     system_u:object_r:ifconfig_exec_t /sbin/ip

Note You need to log in before you can comment on or make changes to this bug.