Bug 150756 - Setup does not create /var/log/lastlog
Setup does not create /var/log/lastlog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 04:40 EST by Alfred Glanzer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-25 08:31:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alfred Glanzer 2005-03-10 04:40:09 EST
Description of problem:
The package setup used to create /var/log/lastlog. This file is no
longer created, which is the cause for a lot of error messages !

Version-Release number of selected component (if applicable):
setup-2.5.40-1

How reproducible:
Always
Comment 1 Bill Nottingham 2005-03-10 11:54:22 EST
Due to the way rpm treats config files (using mmap to verify them),
and the fact that lastlog is a sparse file, lastlog cannot be included
in the package, so it's now a ghost file.

What sort of errors do you see?
Comment 2 Alfred Glanzer 2005-03-11 05:51:12 EST
The errors below show up in /var/log/secure !

Mar 10 16:43:45 freshserver sshd[2881]: lastlog_perform_login:
Couldn't stat /var/log/lastlog: No such file or directory
Mar 10 16:43:45 freshserver sshd[2881]: lastlog_openseek:
/var/log/lastlog is not a file or directory!
Mar 10 16:43:45 freshserver sshd[2881]: lastlog_perform_login:
Couldn't stat /var/log/lastlog: No such file or directory
Mar 10 16:43:45 freshserver sshd[2881]: lastlog_openseek:
/var/log/lastlog is not a file or directory!

When a users logs-in, an attempt is made to write to /var/log/lastlog.
Comment 3 Bill Nottingham 2005-03-11 11:56:12 EST
lastlog is created by shadow-utils on addition of users.
Comment 4 Alfred Glanzer 2005-03-11 11:59:38 EST
That should solve this problem.

However, in my case, all users are created in OpenLDAP, so I do not
know if a lastlog is also created in this special case.
Comment 5 Warren Togami 2005-03-23 00:14:21 EST
Bill, would it be wrong to "touch /var/log/lastlog" sometime during initscripts?
Comment 6 Peter Vrabec 2005-03-25 08:31:28 EST
util-linux will create /var/log/lastlog
#151635

Note You need to log in before you can comment on or make changes to this bug.