Bug 150765 - bind-utils missing resolver.5 manpage
bind-utils missing resolver.5 manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: man-pages (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
RHEL3U7NAK
:
: 155695 (view as bug list)
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2005-03-10 07:49 EST by nathan r. hruby
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0424
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 15:55:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Suggested resolver.5 man-page (7.28 KB, text/plain)
2005-06-01 12:49 EDT, Jason Vas Dias
no flags Details

  None (edit)
Description nathan r. hruby 2005-03-10 07:49:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Hi,

The bind-utils pages traditionally carries a resolver.5 manpage so that
"man resolv.conf" and "man 5 resolver" produce some output.  This appears to not be the case in RHEL3

old.box# cat /etc/redhat-release 
Red Hat Linux release 7.2 (Enigma)
old.box# rpm -qf /usr/share/man/man5/resolver.5.gz
bind-utils-9.2.1-1.7x.2

new.box# cat /etc/redhat-release 
Red Hat Enterprise Linux WS release 3 (Taroon Update 4)
new.box# rpm -qf /usr/share/man/man5/resolver.5.gz
error: file /usr/share/man/man5/resolver.5.gz: No such file or directory
new.box# rpm -q bind-utils
bind-utils-9.2.4-5_EL3
 


Version-Release number of selected component (if applicable):
bind-utils-9.2.4-5_EL3

How reproducible:
Always

Steps to Reproduce:
1.See Description
2.
3.
  

Actual Results:  no manpage

Expected Results:  resolver.5 manpage is shown

Additional info:
Comment 1 Jason Vas Dias 2005-03-10 11:06:08 EST
Yes, sorry - there appears to have been some communication failure
with the glibc maintainers . GLIBC should be providing the
documentation of its resolver, and the glibc maintainers had agreed
to do so, but evidently did not apply this to RHEL-3. 
The resolver.5 manpage provided by BIND dated from 1993 and was 
hopelessly out of date. I'll get an updated resolver man-page 
into the RHEL-3 man-pages for the next release .

Comment 4 Jason Vas Dias 2005-06-01 12:07:04 EDT
The resolver(5) man-page is not shipped in ISC BIND .

BIND does not implement the resolver functionality : glibc does.

Previously, we had shipped a very out-of-date resolver man-page (from 1991 !)
copied from the BSD man-pages, which caused much confusion amongst users.

The man-pages package (or glibc) needs to ship the up-to-date resolver man-page 
in RHEL-3 .

BIND should not ship an out-of-date resolver man-page. We need to ship 
up-to-date documentation for the resolver, as is done for the
resolver(3) man-page, in man-pages.




Comment 5 Jason Vas Dias 2005-06-01 12:49:28 EDT
Created attachment 115041 [details]
Suggested resolver.5 man-page
Comment 9 Vincent Bray 2005-07-21 04:54:56 EDT
*** Bug 155695 has been marked as a duplicate of this bug. ***
Comment 26 Red Hat Bugzilla 2006-05-03 15:55:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0424.html

Note You need to log in before you can comment on or make changes to this bug.