Bug 150772 - [OOo][gcj] ooo's patched rhino fails to build
Summary: [OOo][gcj] ooo's patched rhino fails to build
Status: CLOSED DUPLICATE of bug 151666
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-10 13:48 UTC by Caolan McNamara
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 15:38:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch rhino with this patch (78.63 KB, patch)
2005-03-10 13:49 UTC, Caolan McNamara
no flags Details | Diff
rhino tarball to patch (1.19 MB, application/x-gzip)
2005-03-10 13:51 UTC, Caolan McNamara
no flags Details
FC compatible rhino SRPM (1.65 MB, application/octet-stream)
2005-03-31 15:07 UTC, Anthony Green
no flags Details

Description Caolan McNamara 2005-03-10 13:48:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041220

Description of problem:
Error in comp;ing with ant the attached project when it's patched with the attached patch

Version-Release number of selected component (if applicable):
gcc-java-4.0.0-0.31

How reproducible:
Always

Steps to Reproduce:
tar xvzf rhino15R4.tar.gz
cd rhino1_5R4/
patch -p3 < ../rhino1_5R4.patch
ant -Dbuild.compiler=gcj -f build.xml
  

Actual Results:  ERROR in rhino1_5R4/toolsrc/org/mozilla/javascript/tools/debugger/Main.java (at line 449)
[javac]     int pos = viewToModel(new Point(popup.x, popup.y));

Expected Results:  .

Additional info:

This is an extracted module from OOo 2

Comment 1 Caolan McNamara 2005-03-10 13:49:08 UTC
Created attachment 111852 [details]
patch rhino with this patch

Comment 2 Caolan McNamara 2005-03-10 13:51:12 UTC
Created attachment 111853 [details]
rhino tarball to patch

Comment 3 Thomas Fitzsimmons 2005-03-10 15:59:46 UTC
This looks like a bug in libgcj's Swing implementation.  Can you assign bugs you
suspect are libgcj GUI bugs to me please?  I'll look into this.


Comment 4 Anthony Green 2005-03-31 15:05:40 UTC
The code that doesn't build is only for the javascript GUI debugger.   I suspect
that OO.o doesn't use this.   I will attach an SRPM that should work.  It will
require the xmlbeans from JPackage.

If this works, we should move these packages into rawhide.

Comment 5 Anthony Green 2005-03-31 15:07:12 UTC
Created attachment 112513 [details]
FC compatible rhino SRPM

Comment 6 Thomas Fitzsimmons 2005-03-31 15:36:40 UTC
I committed a fix for the missing Swing method to GCC HEAD and gcc-4_0-branch. 
Rhino should build unmodified now.

Comment 7 Thomas Fitzsimmons 2005-03-31 15:38:27 UTC

*** This bug has been marked as a duplicate of 151666 ***


Note You need to log in before you can comment on or make changes to this bug.