Bug 150784 - mdadm display strange message on boot: super-minor once, super-minor=1 ignored.
mdadm display strange message on boot: super-minor once, super-minor=1 ignored.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mdadm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2005-03-10 11:04 EST by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0290
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I'm having problems attatching from the IT, so i'll post it directly. Here is the patch pulled from FC4 that should fix the problem. (1.37 KB, patch)
2006-05-22 12:48 EDT, Josef Bacik
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2005-03-10 11:04:00 EST
Description of problem:
After installation RHEL 4 with /boot and / on 2 RAID 1 mirrors after
boot a strange message is displayes

Version-Release number of selected component (if applicable):
mdadm-1.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 and define in disk-druid RAID 1 for /boot and / 
2. Reboot
    

Actual Results:  Setting up Logical Volume Management: [  OK  ]
mdadm: only specify super-minor once, super-minor=1 ignored.
mdadm: only specify super-minor once, super-minor=0 ignored.
Checking filesystems

Expected Results:  No such strange messages

Additional info:

# cat /etc/mdadm.conf

# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md1 super-minor=1
ARRAY /dev/md0 super-minor=0

(generated during installation)
Comment 1 Andreas Thienemann 2005-06-07 17:43:37 EDT
Additionally, the content of the mdadm.conf file is completely bogus. Feeding
the content of the autogenerated config file to mdadm trying to initially build
a raidset will fail.
Comment 3 Josef Bacik 2006-05-22 12:48:14 EDT
Created attachment 129815 [details]
I'm having problems attatching from the IT, so i'll post it directly.  Here is the patch pulled from FC4 that should fix the problem.
Comment 4 Daniel Riek 2006-08-28 18:18:11 EDT
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this request by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This request is not yet committed for inclusion in an Update release. 
Comment 6 Doug Ledford 2007-01-31 13:18:35 EST
A patch has been included in mdadm-1.12.0-2 that should solve this problem
(there was an invalid test in config.c that caused mdadm to think that
super-minor had been seen already when it actually hadn't, correcting the test
makes things work as expected).
Comment 10 Red Hat Bugzilla 2007-05-01 13:46:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0290.html
Comment 11 Peter Bieringer 2007-05-09 08:46:25 EDT
Since at least last update to mdadm-1.12.0-2 (RHEL4 U5) now following appears:

Setting up Logical Volume Management: [  OK  ]                                  
mdadm: ARRAY line /dev/md0 has no identity information.                         
mdadm: ARRAY line /dev/md1 has no identity information.                         
mdadm: ARRAY line /dev/md2 has no identity information.                         
mdadm: ARRAY line /dev/md3 has no identity information.                         
mdadm: ARRAY line /dev/md4 has no identity information.                         
mdadm: ARRAY line /dev/md5 has no identity information.                         
mdadm: ARRAY line /dev/md6 has no identity information.                         
mdadm: ARRAY line /dev/md7 has no identity information.                         
mdadm: ARRAY line /dev/md8 has no identity information.                         
mdadm: ARRAY line /dev/md9 has no identity information.                         
mdadm: No arrays found in config file


Current configuration:

# cat /etc/mdadm.conf                                               
                                                                                
# mdadm.conf written out by anaconda                                            
DEVICE partitions                                                               
MAILADDR root                                                                   
ARRAY /dev/md0                                                                  
ARRAY /dev/md1                                                                  
ARRAY /dev/md2                                                                  
ARRAY /dev/md3                                                                  
ARRAY /dev/md4                                                                  
ARRAY /dev/md5                                                                  
ARRAY /dev/md6                                                                  
ARRAY /dev/md7                                                                  
ARRAY /dev/md8                                                                  
ARRAY /dev/md9

After adding "uuid=..", messages are gone now.

BTW:

# mdadm --query --detail /dev/md0
..

           UUID : 88dfe44e:a5bdb37a:0d09d7ee:267304da
         Events : 0.275046  

Should "Events" being representated as floating point or what does this value mean?

Note You need to log in before you can comment on or make changes to this bug.