Bug 150822 - post ftp install - so.4 libs needed so.5 ssl libs only present
post ftp install - so.4 libs needed so.5 ssl libs only present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 18:20 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 21:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2005-03-10 18:20:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050308 Fedora/1.7.5-6

Description of problem:
After performing an ftp install from development, packages were pulled
in for newer ssl  libraries and removed were the below libraries that
are not now in the upgraded installation. Since mutt (now fixed) was
broken also and required the older libraries at the time, I symlinked
the symlinks to point to the below listed files. All seems to be
alright with up2date, except the forward button is not active. Below
is the symlink listing through ls -la for the older libraries. Below
that is the shell output fro up2date.
 ls -la *.so.4
lrwxrwxrwx  1 root root 19 Mar 10 17:33 libcrypto.so.4 ->
/lib/libcrypto.so.5
lrwxrwxrwx  1 root root 16 Mar 10 17:32 libssl.so.4 -> /lib/libssl.so.5



 up2date --nosig
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 27, in ?
    from up2date_client import repoDirector
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 5, in ?
    import rhnChannel
  File "/usr/share/rhn/up2date_client/rhnChannel.py", line 10, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 5, in ?
    import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 22, in ?
    from rhn import rpclib
  File "/usr/lib/python2.4/site-packages/rhn/__init__.py", line 11, in ?
    import rpclib
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 14, in ?
    import transports
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 24, in ?
    import connections
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 14,
in ?
    import SSL
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 15, in ?
    from OpenSSL import SSL, crypto
  File "/usr/lib/python2.4/site-packages/OpenSSL/__init__.py", line
11, in ?
    import rand, crypto, SSL, tsafe
ImportError: libcrypto.so.4: cannot open shared object file: No such
file or directory
[root@cornette-fc3-lt lib]# mc

[root@cornette-fc3-lt lib]# up2date --nosig

(up2date:3040): GLib-GObject-WARNING **: invalid cast from
`GnomeDruidPageEdge' to `GtkWindow'

(up2date:3040): GLib-GObject-WARNING **: invalid cast from
`GnomeDruidPageStandard' to `GtkWindow'

(up2date:3040): GLib-GObject-WARNING **: invalid cast from
`GnomeDruidPageStandard' to `GtkWindow'
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/checklist.py", line 148, in
_button_press_cb
    self._toggle_row (info[0])
  File "/usr/share/rhn/up2date_client/checklist.py", line 134, in
_toggle_row
    self.toggled_func(val, row_data)
  File "/usr/share/rhn/up2date_client/gui.py", line 281, in
updateSelectedSize
    self.__updateSelectedSizeLabel(sizeLabel, state, rowData)
  File "/usr/share/rhn/up2date_client/gui.py", line 275, in
__updateSelectedSizeLabel
    self.pkgsSelected = self.pkgsSelected + 1
TypeError: unsupported operand type(s) for +: 'instance' and 'int'
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/checklist.py", line 148, in
_button_press_cb
    self._toggle_row (info[0])
  File "/usr/share/rhn/up2date_client/checklist.py", line 134, in
_toggle_row
    self.toggled_func(val, row_data)
  File "/usr/share/rhn/up2date_client/gui.py", line 281, in
updateSelectedSize
    self.__updateSelectedSizeLabel(sizeLabel, state, rowData)
  File "/usr/share/rhn/up2date_client/gui.py", line 275, in
__updateSelectedSizeLabel
    self.pkgsSelected = self.pkgsSelected + 1
TypeError: unsupported operand type(s) for +: 'instance' and 'int'
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/checklist.py", line 148, in
_button_press_cb
    self._toggle_row (info[0])
  File "/usr/share/rhn/up2date_client/checklist.py", line 134, in
_toggle_row
    self.toggled_func(val, row_data)
  File "/usr/share/rhn/up2date_client/gui.py", line 281, in
updateSelectedSize
    self.__updateSelectedSizeLabel(sizeLabel, state, rowData)
  File "/usr/share/rhn/up2date_client/gui.py", line 275, in
__updateSelectedSizeLabel
    self.pkgsSelected = self.pkgsSelected + 1
TypeError: unsupported operand type(s) for +: 'instance' and 'int'


Version-Release number of selected component (if applicable):
up2date-4.4.9-1, > openssl-0.9.7e-3openssl-0.9.7e-3, python-2.4-4

How reproducible:
Always

Steps to Reproduce:
1. upgrade installation via mirror from development
2. Get message which requires using  mutt.
3. create symlinks from newer so.5 symlinks to point to missing older
symlinks.
4. mutt gets fixed, remove symlinks
5. try to run up2date, requires so.4 libs
6. recreate symlinks and only get so far with package selection.
    

Actual Results:  Without symlinks, errors that point to so.4 libs
needed. With symlinks, get to package selection, but get no further
because of error listed in above traceback.

Expected Results:  Up2date to have been upgraded to be able to
function without any problems. up2date should be ahead of other
package requirements because of its importance to upgrade the system.


Additional info:
Comment 1 Jeremy Katz 2005-04-27 21:08:40 EDT
This should be better now I think.
Comment 2 Jim Cornette 2005-04-28 22:53:10 EDT
Other than the button problem where this error was first noted, the latest
changes to up2date-gnome-4.4.17-1 show the below:

 up2date --nosig
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1231, in exceptionHandler
    log = up2dateLog.initLog()
NameError: global name 'up2dateLog' is not defined

Original exception was:
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1311, in onChannelsPageNext
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 125, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 331, in
getAvailableAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    repos = repoDirector.initRepoDirector()
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 75, in initRepoDirector
    from repoBackends import repomdRepo
  File "/usr/share/rhn/up2date_client/repoBackends/repomdRepo.py", line 16, in ?
   import yumBaseRepo
  File "/usr/share/rhn/up2date_client/repoBackends/yumBaseRepo.py", line 14, in ?
    import yum
  File "/usr/share/rhn/__init__.py", line 32, in ?

ImportError: No module named updates
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1231, in exceptionHandler
    log = up2dateLog.initLog()
NameError: global name 'up2dateLog' is not defined

Original exception was:
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1393, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: max() arg is an empty sequence
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1231, in exceptionHandler
    log = up2dateLog.initLog()
NameError: global name 'up2dateLog' is not defined

Original exception was:
TypeError: hide() takes no arguments (2 given)

I've been using other methods to update recently. I do feel that there is
something important that changed from the libssl.so. to libssl.so.5 that up2date
depended upon.

Thanks!

Jim

Note You need to log in before you can comment on or make changes to this bug.