Bug 150844 - kickstart fails to assign IP address to interface
Summary: kickstart fails to assign IP address to interface
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-11 10:02 UTC by Kurt Keller
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-220
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 20:37:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:220 normal SHIPPED_LIVE anaconda bug fix update 2005-06-09 04:00:00 UTC

Description Kurt Keller 2005-03-11 10:02:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
We usually kickstart our machines the following way:
1) boot from the distro's installation CD
2) at the first prompt enter
   'linux ks=http://our.satellite.server/path/to/kickstart'
3) in the server networks we don't have DHCP, so wait for the
   DHCP request to timeout and the screen to appear asking for
   for the IP settings and specify those settings
4) burn your tongue if you go for a coffee because the install is
   blindingly fast and you have to slurp your coffee really hot ;-)

Works perfectly well and we're happy with this procedure. However,
with the ISO images for RHEL4 this does not work. Tried the images
for RHEL4-WS/DT/AS, also verified the md5sum.

With the RHEL4 installation CD, the prompt (step3) appears but the
settings are not applied to the network interface. Long timeouts and
nothing happens. After a loooong time, finally, the system asks whether
to check the CD and continue with a CD installation. Saying yes and going
slightly further, a shell becomes available at tty2 and doing an ifconfig
from there shows that the network interface does not have any IP address
assigned.

Sofar the only way around the issue I have found is to create a custom
CD for the machines and include all IP parameters in the append line of
the custom label (or enter everything painstakingly at the boot prompt):
label vm251
  kernel vmlinuz
  append text \
         ks=http://ip-of-satellite-server/kickstart/ks/label/mylabel  \
         initrd=initrd.img \
         lang= \
         devfs=nomount \
         ramdisk_size=8192 \
         ksdevice=eth0 \
         ip=192.168.111.111 \
         netmask=255.255.255.0 \
         gateway=192.168.111.11 \
         nameserver=172.17.172.17 \
         device=eth0


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux WS release 4 (Nahant)

How reproducible:
Always

Steps to Reproduce:
1. boot from RHEL4 installation cd in a network without DHCP
2. at boot prompt enter 'linux ks=http://satelliteserver/path/to/kickstart'
3. wait for DHCP request to timeout and the IP settings mask to appear
4. enter the IP settings
  

Actual Results:  system fails to apply the entered IP address to the network card and thus can
not install

Expected Results:  system should apply the entered IP addresses to the network card and install

Additional info:

Comment 2 Chris Lumens 2005-03-28 20:37:36 UTC

*** This bug has been marked as a duplicate of 149871 ***

Comment 4 Tim Powers 2005-06-09 11:29:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-220.html



Note You need to log in before you can comment on or make changes to this bug.