Bug 150846 - kernel compile error with static kernel and e100
kernel compile error with static kernel and e100
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 05:34 EST by Arndt Koenigsfeld
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-11 18:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
e100-mii-built_in.patch (355 bytes, patch)
2005-03-14 08:58 EST, John W. Linville
no flags Details | Diff

  None (edit)
Description Arndt Koenigsfeld 2005-03-11 05:34:58 EST
Description of problem:
does not compile as static kernel and enabled e100 and disabled eepro100.

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-27.0.2.EL

How reproducible:
allways

Steps to Reproduce:
1.# CONFIG_MODULES is not set
2.# CONFIG_EEPRO100_PIO is not set
3.CONFIG_E100=y
4.make bzImage
  
Actual results:
ld -m elf_i386 -T /usr/src/linux-2.4.21-27.0.2.EL/arch/i386/vmlinux.lds -e stext arch/
i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o init/
do_mounts.o --start-group arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/
kernel.o mm/mm.o fs/fs.o ipc/ipc.o  drivers/char/char.o drivers/block/block.o drivers/
misc/misc.o drivers/net/net.o drivers/ide/idedriver.o drivers/scsi/scsidrv.o drivers/
cdrom/driver.o drivers/pci/driver.o drivers/pnp/pnp.o drivers/video/video.o drivers/
media/media.o drivers/message/i2o/i2o.o drivers/md/mddev.o drivers/hotplug/vmlinux-
obj.o net/network.o /usr/src/linux-2.4.21-27.0.2.EL/arch/i386/lib/lib.a /usr/src/linux
-2.4.21-27.0.2.EL/lib/lib.a /usr/src/linux-2.4.21-27.0.2.EL/arch/i386/lib/lib.a --end-
group  -o vmlinux
drivers/net/net.o(.text+0x2a204): In function `e100_watchdog':
: undefined reference to `mii_ethtool_gset'
drivers/net/net.o(.text+0x2a20c): In function `e100_watchdog':
: undefined reference to `mii_link_ok'
drivers/net/net.o(.text+0x2a237): In function `e100_watchdog':
: undefined reference to `mii_check_link'
drivers/net/net.o(.text+0x2a324): In function `e100_watchdog':
: undefined reference to `mii_link_ok'
drivers/net/net.o(.text+0x2b4b6): In function `e100_set_settings':
: undefined reference to `mii_ethtool_sset'
drivers/net/net.o(.text+0x2b9b8): In function `e100_diag_test':
: undefined reference to `mii_link_ok'
drivers/net/net.o(.text+0x2ba3e): In function `e100_diag_test':
: undefined reference to `mii_ethtool_gset'
drivers/net/net.o(.text+0x2ba9b): In function `e100_diag_test':
: undefined reference to `mii_ethtool_sset'
drivers/net/net.o(.text+0x2bcef): In function `e100_do_ioctl':
: undefined reference to `generic_mii_ioctl'
drivers/net/net.o(.text+0x2b461): In function `e100_get_settings':
: undefined reference to `mii_ethtool_gset'
drivers/net/net.o(.text+0x2b771): In function `e100_nway_reset':
: undefined reference to `mii_nway_restart'
drivers/net/net.o(.text+0x2b791): In function `e100_get_link':
: undefined reference to `mii_link_ok'
make[1]: *** [kallsyms] Fehler 1
make[1]: Verlassen des Verzeichnisses Verzeichnis Âť/usr/src/linux-2.4.21-27.0.2.ELÂŤ
make: *** [vmlinux] Fehler 2


Expected results:
no errors

Additional info:
i need a static kernel with e100 and e1000 (does NOT work with EEPRO100)
Comment 1 Ernie Petrides 2005-03-11 18:23:52 EST
Customer-altered configurations are not supported.  But please feel free
to develop fixes and promote them upstream.  If fixes are adopted in the
2.4 upstream kernel, then they are likely to filter down into an e100
driver upgrade during a future RHEL3 update.
Comment 2 Arndt Koenigsfeld 2005-03-13 16:42:34 EST
2.4.21 from kernel.org compiles without errors with same configuration.
I will try to find the differences tomorrow.
Comment 3 John W. Linville 2005-03-14 08:58:01 EST
Created attachment 111978 [details]
e100-mii-built_in.patch

Looks like you are missing mii.o...you may want to try this patch...

Note You need to log in before you can comment on or make changes to this bug.