Bug 150890 - Printer not working
Printer not working
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
Depends On:
Blocks: 176344
  Show dependency treegraph
Reported: 2005-03-11 13:25 EST by Siamack Haghighi
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-02 08:06:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The requested error log file: /var/log/cups/error_log (18.10 KB, application/octet-stream)
2005-03-11 14:59 EST, Siamack Haghighi
no flags Details

  None (edit)
Description Siamack Haghighi 2005-03-11 13:25:31 EST
Description of problem:

Printer not working when trying to print a web page or a file.

Version-Release number of selected component (if applicable):

How reproducible:

I am using a user account. I tried to print a page from mozilla firefox and
nothing shows up. 

Steps to Reproduce:
1. The printer is configured using root account. The test page does come out to
be OK. The printer uses jetdirect and is xerox phaser 8400. The ppd file is also
loaded correctly and selected as the driver for the printer.
2. I logged in as a user and had to set up the printer configuration again
(require root password). That works fine. 
3. I tried to print a web page and nothing shows up.
4. I tried to printe from an xemacs window and get the following error: lpr:
error - scheduler not responding.
Actual results:

Expected results:

Additional info:
Comment 1 Tim Waugh 2005-03-11 14:02:38 EST
Please attach the file /var/log/cups/error_log.  Thanks.
Comment 2 Siamack Haghighi 2005-03-11 14:59:32 EST
Created attachment 111902 [details]
The requested error log file: /var/log/cups/error_log

The requested error log file
Comment 3 Tim Waugh 2005-03-14 06:04:37 EST
Does /etc/hosts contain this line?:               localhost.localdomain localhost
Comment 4 Siamack Haghighi 2005-03-14 11:06:33 EST
(In reply to comment #3)
> Does /etc/hosts contain this line?:
>               localhost.localdomain localhost

Yes, it does. In addition, there is a comment line before this line stating that
this line should not be changed, otherwise the network functionality will not
work. I added another line with the right network IP address for the host
machine (does this make the machine appear as having two IP addresses?
and the other IP address)?

Comment 5 Tim Waugh 2005-04-11 07:28:44 EDT
The error_log file shows several problems with hostname look-ups.  Is DNS
working correctly for you otherwise?
Comment 6 Milan Kerslager 2005-09-08 16:39:29 EDT
I had DNS lookups errors too even I have working DNS and ping to DNS name works
too. The same configuration works on RHEL3 since update to RHEL4. I had to
change DNS names to IP addresses of the printers in the /etc/cups/cupsd.conf file.
This is fully up-to-date system with regular RHN account, the line with is present in the hosts file.
Comment 7 Tim Waugh 2005-09-09 09:49:59 EDT
This is some sort of problem stemming from those DNS lookup failures.

E [09/Mar/2005:14:19:06 -0500] StartListening: Unable to find IP address for
server name "localhost.localdomain" - Host name lookup failure
E [10/Mar/2005:11:50:03 -0800] [Job 1] Unable to locate printer 'xeroxp8400cl' -
Unknown host

The /etc/hosts file looks right.  Not sure what's up really.

What other sorts of DNS lookup errors did you have?
Comment 8 Milan Kerslager 2006-01-07 05:43:17 EST
This may be a duplicate of the bug #168749 (in the case DNS is not a problem).
Comment 9 Tim Waugh 2006-05-02 08:06:14 EDT
No feedback since comment #7.
Comment 10 Milan Kerslager 2006-07-25 16:36:16 EDT
As of my experiencies from CUPS based printer servers on Samba (ie MS-Win)
networks with some Linux workstations, there is actually no problem with CUPS in
RHEL4 except CUPS disables printing automagically if the printer is some time in
error state (offline, unplugged, paper jam etc).

You have to run "lpc status" and watch about "disabled" printing then run you
have to use full path as 'enable' is internal command of bash shell):

/usr/bin/enable PRINTER_NAME

You may use this to auto-enable printer by cron daemon:

/usr/sbin/lpc status | grep -B4 "printing is disabled" | \
  grep : | tr -d ":" | xargs --max-args=1 /usr/bin/enable

Note You need to log in before you can comment on or make changes to this bug.