Bug 150932 - yum does not function - sqlite sees to be mentioned in bt
yum does not function - sqlite sees to be mentioned in bt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 23:24 EST by Jim Cornette
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-12 01:42:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2005-03-11 23:24:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
After upgrading many packages sucessfully via yum, I am now not able
to get yum to function following a system restart. I get the below
backtrace. Also, my system is currently upgraded to most recent
packages via up2date. I could not use yum because of the failure with yum.

Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 72, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 471, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 960, in updatePkgs
    self.doUpdateSetup()
  File "__init__.py", line 228, in doUpdateSetup
  File "sqlitesack.py", line 225, in returnObsoletes
  File
"/usr/src/build/515186-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py",
line 104, in __getitem__
KeyError: 'PACKAGES.PKGID'


Version-Release number of selected component (if applicable):
yum-2.3.1-1 sqlite-3.1.2-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade system via yum, pull in many updates successfully
2. shut system down for night, after successful update via yum
3. try yum to update when upgrades present
    

Actual Results:  I had to remove devhelp for mozilla related packages,
rpm-devel followed by sqlite3-devel to resolve other conflicts.
Afterwards the update process completed successfully.
When trying yum to upgrade system, the backtrace is all I could get to
with the program. After upgrading via up2date, the error is still present.

Expected Results:  A working tool.

Additional info:

Somebody mentioned sqlite broke yum on the development list. (Sandy Pond) 
At the time, I thought yum was still functional. I did not try to run
yum just after updating.
Comment 1 Seth Vidal 2005-03-12 01:41:22 EST
1. the bug keeping yum from working absent sqlite is fixed upstream in
cvs.
2. the absence of python-sqlite is just a temporary problem in
rawhide, reinstall the older python-sqlite3 package and you're on your
way.
Comment 2 Jim Cornette 2005-03-12 16:26:02 EST
I'll hold on until a working python-sqlite hits rawhide. The yum clean
packages, clean all and clean headers still works. I cleared the
package caches (no older programs availble)and can bear waiting for
the newer cvs version to hit rawhide.
Up2date carries on, even though the GUI for up2date is broken
currently in rawhide.

Thanks!
Jim
Comment 3 Jim Cornette 2005-03-12 16:50:02 EST
I just tried to install python-sqlite from rawhide and was presented
with the below output.
rpm -Uvh pyt*.rpm
error: Failed dependencies:
        python-sqlite3 is needed by (installed) yum-2.3.1-1.noarch

 rpm -q python-sqlite3
python-sqlite3-1.1.6-1


I am trying to install python-sqlite-1.1.6-1.i386.rpm when I got the
error. Installing the listed version shows the below traceback. The
above traceback was with sqlite3 installed.

Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 72, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 471, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 960, in updatePkgs
    self.doUpdateSetup()
  File "__init__.py", line 228, in doUpdateSetup
  File "sqlitesack.py", line 225, in returnObsoletes
  File
"/usr/src/build/539311-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py",
line 104, in __getitem__
KeyError: 'PACKAGES.PKGID'
same error, I believe.

Note You need to log in before you can comment on or make changes to this bug.