This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 150948 - GCC GNAT has output at installing
GCC GNAT has output at installing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-12 10:35 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.0.0-0.34
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 03:08:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-12 10:35:41 EST
Description of problem:
GCC GNAT has output at installing:

--- snipp ---
# rpm -Uvh gcc-gnat-4.0.0-0.32.i386.rpm
Preparing...                ########################################### [100%]
   1:gcc-gnat               ########################################### [100%]
install-info: menu item `GNAT User's Guide' already exists, for file `gnat_ug'
# 
--- snapp ---

Version-Release number of selected component (if applicable):
gcc-4.0.0-0.32

How reproducible:
Everytime at upgrading, see above.

Actual results:
Output at installing.

Expected results:
No output at installing.
Comment 1 Jakub Jelinek 2005-03-16 06:23:51 EST
Should be fixed in gcc-4.0.0-0.34.
Comment 2 Robert Scheck 2005-03-17 11:51:39 EST
No, it isn't - reopening.
Comment 3 Jakub Jelinek 2005-03-18 03:08:07 EST
I certainly can't reproduce this:
$ rpm -Uvh gcc-gnat-4.0.0-0.34.i386.rpm
Preparing...                ########################################### [100%]
   1:gcc-gnat               ########################################### [100%]
$
Make sure you uninstall old gcc-gnat first, it might very well keep something
bogus in /usr/share/info/dir because of the bug in older gcc-gnat.

But, the broken gcc-gnat has never been released as part of stable distro
or its updates, so doing ugly workarounds is not desirable (it would mean
carrying them around forever).
Comment 4 Jan Houtsma 2005-04-13 10:03:11 EDT
Last nights up2date on Fedora FC3 (libgnat-3.4.3-22.fc3.i386.rpm):

  14:gcc-gnat               ########################################### [100%]
install-info: menu item `GNAT User's Guide' already exists, for file `gnat_ug'

Note You need to log in before you can comment on or make changes to this bug.