Bug 150950 - nv corrupted screen
Summary: nv corrupted screen
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-12 15:53 UTC by Zachary Whitley
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 06:14:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (35.14 KB, text/plain)
2005-03-18 14:23 UTC, Zachary Whitley
no flags Details

Description Zachary Whitley 2005-03-12 15:53:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:


this appears to be the exact same problem as experienced with the i810/i815 drivers. (bug 132267)

When X comes up images are "blocky" and window. The addition of Option "NoAccel" allows X to come up.

kernel 2.6.10-1.770_FC3
xorg-x11-6.8.1 (tried development xorg-x11-6.8.2, didn't fix problem)

Video Card: nVidia GeForce2 Go

lspci 
00:05.0 VGA compatible controller: nVidia Cororation NV11 [GeForce2 Go] (rev b2)

Machine: Compaq TC-1000
CPU: Transmetta Crusoe Processor TM5800

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1/xorg-x11-6.8.2

How reproducible:
Always

Steps to Reproduce:
1.text install (graphical install is corrupted)
2.boot, edit boot line, remove "quite rhgb", add init 3
3.startx => corrupted (hard reboot)
4.same as above
5.Edit xorg.conf adding Option "NoAccel"
6.startx => ok
  

Additional info:

Comment 1 Zachary Whitley 2005-03-15 03:11:38 UTC
mtrr support is compiled into the kernel but the crusoe doesn't seem to support
mtrr. I'm not sure if this an issue or not but I thought that I'd mention it.

Comment 2 Mike A. Harris 2005-03-18 06:24:37 UTC
Upgrade to the current xorg-x11-6.8.2 in fedora core 3 "testing", which is
going to be released in a few days as an official update.  If the problem
still occurs, using the "nv" driver, please attach your X server log file and
config file to the report using the link below.

Comment 3 Zachary Whitley 2005-03-18 14:23:26 UTC
Created attachment 112124 [details]
Xorg log file

Comment 4 Zachary Whitley 2005-03-18 14:24:43 UTC
Upgraded to xorg 6.8.2, still corrupted.

[root@tarawa ~]# rpm -qa | grep xorg
xorg-x11-xauth-6.8.2-7
fonts-xorg-100dpi-6.8.1-1
xorg-x11-font-utils-6.8.2-7
xorg-x11-Xvfb-6.8.2-7
xorg-x11-deprecated-libs-6.8.2-7
xorg-x11-Mesa-libGL-6.8.2-7
xorg-x11-6.8.2-7
xorg-x11-twm-6.8.2-7
fonts-xorg-base-6.8.1-1
xorg-x11-libs-6.8.2-7
xorg-x11-xfs-6.8.2-7
xorg-x11-tools-6.8.2-7
fonts-xorg-75dpi-6.8.1-1
xorg-x11-doc-6.8.2-7
xorg-x11-devel-6.8.2-7
xorg-x11-Mesa-libGLU-6.8.2-7
xorg-x11-xdm-6.8.2-7
[root@tarawa ~]# uname -a
Linux tarawa 2.6.10-1.770_FC3 #1 Thu Feb 24 14:00:06 EST 2005 i686 i686 i386
GNU/Linux
[root@tarawa ~]# rpm -qa | grep kernel
kernel-utils-2.4-13.1.49_FC3
kernel-2.6.10-1.770_FC3


Comment 5 Zachary Whitley 2005-05-04 17:12:17 UTC
This seems to have been a hardware problem. I sent it back to HP/Compaq and now
it seems to be fine.

(As a side note for anyone googling this post the latest nvidia 1.0-7174 drivers
are also working for the Compaq TC-1000.)

This can be closed. 


Note You need to log in before you can comment on or make changes to this bug.