Bug 150954 - can't install with USB DVD and CD-ROM media
can't install with USB DVD and CD-ROM media
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-12 13:23 EST by Dan Ryan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 16:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Ryan 2005-03-12 13:23:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Trying to install RHEL 4 on a Dell PowerEdge 750 - with an external USB 2.0 DVD-R drive, using CD-R media. When completing initial setup with Disk 1 and placing Disk 2 into drive, process errors indicating the media is corrupt.

In acuality it was unable to mount the media since it was attempting to mount /tmp/sda0 rather than /tmp/cdrom thus causing the error.

A work around is to go into the Virtual Console (ALT-DEL-F2) and perform the mount by hand then go back to the Interface (ALT-DEL F7) and allow the retry of the Disk 2.

This seems to allow the install to proceed to completion.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use CD media with a USB DVD device
2.
3.
  

Actual Results:  You get frustrated... and wish you paid the extra 200 bucks for a CD drive on the system.

Expected Results:  It should install and make you feel rewarded that you can do simple tasks

Additional info:

This should be addressed, installations are the first thing a new user sees, perceptions are everything!!!
Comment 1 Jeremy Katz 2005-03-14 13:41:36 EST
Can you provide /tmp/anaconda.log and /tmp/syslog at the point where it fails?
Comment 2 Dan Ryan 2005-03-14 13:59:31 EST
not at this point -- I completed the install using method described above, and 
moved on getting the system to production.

Its easy I'm sure to recreate - just use a server with a external DVD drive and 
the CD media. The same issue reproduced on 3 different drives, until I went 
Duh! and figured out what it was really complaining about.
Comment 3 Mitchell Brandsma 2005-05-02 23:04:52 EDT
Our situation shows the problem is deeper than this.  I'm trying to install on 
an IBM HS20 blade (dual Xeon 2.8G HT), with several SCSI devices available on a 
SAN, causing the (usb-storage) CD-ROM device to be /dev/sdm.  The bladecenter 
shares its management and IO modules to blades through USB interfacing.  In 
this case I make sure both are assigned to the blade I'm installing on before 
power-up.

I should also note that there have been no installation issues of this sort on 
any of the EL3 installs I've done on these systems, and that the disks are read 
fine otherwise by the systems using the shared IO tray, and have been used to 
install on a system with a non-USB CDROM drive.

During initialisation it loads the usb-storage module, loads the qla2300 module 
and apparently again the usb-storage module, or perhaps further related 
modules.  I can choose the NFS option for source media, no problem, and the 
install works after a fashion (different bug report which has little to do with 
this) - definitely no problems doing the installation itself anyway.  However, 
choosing the CDROM install option, results in the following message, headed "CD 
Not Found":

The Red Hat Enterprise Linux CD was not found in any of your CDROM drives.  
Please insert the Red Hat Enterprise Linux CD and press OK to retry.

If I hit OK, the message is refreshed immediately after letting the "ok button" 
up with no change.

I have tried switching the IO tray to another blade and back, but all that does 
is unload the USB module, and re-load it (as it should).  Nothing about the 
appearance of the new drive letter (sdm) though.
Comment 4 Michael Napolis 2005-05-12 19:13:06 EDT
RHEL4 U1 Beta works but not with RHEL4 GA
Comment 5 Mitchell Brandsma 2005-05-12 19:28:04 EDT
Indeed, U1 Beta works to resolve our issue with the usb-storage CDROM too.  
However, I believe one of our guys tried to use the floppy drive at boot 
(kickstart install) and although it detected the floppy, it failed to recognise 
that a disk was in the drive.  Probably a seperate issue.
Comment 6 Jeremy Katz 2005-05-16 16:49:20 EDT
If U1 beta works, then this is due to a kernel bug which was resolved for U1.

Note You need to log in before you can comment on or make changes to this bug.