Bug 150963 - RFE: Yum should list what it's going to delete
RFE: Yum should list what it's going to delete
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-12 17:28 EST by Ivan Gyurdiev
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 14:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-03-12 17:28:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Yum does not list what it's erasing, and that's not very nice.
The user should be informed of _all_ the changes happening to his (or her)
system. 

For example, I install stuff from cvs, and add it to a fake rpm
to keep the rpm database happy. 

The example below shows what happens when I attempt to install a new package,
which is part of the rpm mentioned above (not a bright move on my part).
As a result yum tries to remove that rpm, and all the things it provides
have to be reinstalled. That's what I would expect it would do, 
however I'd like to be informed that it's trying to remove stuff, so I don't
have to figure it out on my own.

Version-Release number of selected component (if applicable):
yum-2.3.1-1

How reproducible:
Didn't try

Steps to Reproduce:
  

Actual Results:  Transaction Listing:
  Install: nautilus-cd-burner.i386 0:2.10.0-1 - development

Performing the following to resolve dependencies:
  Install: eel2.i386 0:2.9.91-2 - development
  Install: libgnomeprint22.i386 0:2.8.2-2 - development
  Install: libgnomeprint22-devel.i386 0:2.8.2-2 - development
  Install: nautilus.i386 0:2.9.91-2 - development


Expected Results:  Transaction Listing:
  Install: nautilus-cd-burner.i386 0:2.10.0-1 - development

Performing the following to resolve dependencies:
  Erase: fake-source-provides-5.0-1
  Install: eel2.i386 0:2.9.91-2 - development
  Install: libgnomeprint22.i386 0:2.8.2-2 - development
  Install: libgnomeprint22-devel.i386 0:2.8.2-2 - development
  Install: nautilus.i386 0:2.9.91-2 - development

Additional info:
Comment 1 Ivan Gyurdiev 2005-05-12 01:27:39 EDT
What's the status of this bug - yum still does not list what it's going to erase.

Comment 2 Seth Vidal 2005-05-12 01:31:28 EDT
why do you think yum is erasing this package?
Comment 3 Ivan Gyurdiev 2005-05-12 02:28:15 EDT
Because it's installing unrelated dependencies?

Why would it want to install eel2, when I already provide that
dependency in the fake-source-provides package? It seems
clear that it's getting rid of it - the dependency set
being installed matches perfectly the dependencies that
package provides.


Comment 4 Seth Vidal 2005-05-12 02:32:58 EDT
I'm betting it doesn't actually match perfectly. I'm betting it is off by enough
to cause yum to pull in the new ones.

Oh and just so you know - excluding obsoletes (which is only an implicit erase)
yum will NEVER erase any package on install/update.

Comment 5 Ivan Gyurdiev 2005-05-12 02:49:20 EDT
Let's look at a simpler case - I no longer use the packages above, and I can't
test with those, but I now have: wine, wine-devel, scribus, ORBit2, and
ORBit2-devel in the fake package. Nothing depends on wine, wine-devel,
or scribus, so ORBit is the package(s) of interest.

Starting up yum. The task: Install ORBit2 - a rather stupid task, given
that the depdency is already present (fake), but I assume yum looks
for the package, not for the dependency, and can't find it.

First, it takes forever to resolve dependency - I don't know why, I just updated
400 packages at reasonable speed today with the same yum. CPU is ~0, disk
activity is very high. 

Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ORBit2.i386 0:2.12.1-3 set to be updated
--> Running transaction check
--> Processing Dependency: ORBit2-devel for package: gnome-pilot-devel
--> Processing Dependency: ORBit2-devel >= 2.6.0 for package: libgnomeui-devel
--> Processing Dependency: ORBit2-devel >= 2.7.5 for package: libbonobo-devel
--> Processing Dependency: ORBit2-devel >= 2.5.1 for package: libbonoboui-devel
--> Processing Dependency: ORBit2-devel >= 2.5.1 for package: libgnome-devel
--> Processing Dependency: ORBit2-devel >= 2.8.0 for package: GConf2-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ORBit2-devel.i386 0:2.12.1-3 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 ORBit2                  i386       2.12.1-3         development       234 k
Installing for dependencies:
 ORBit2-devel            i386       2.12.1-3         development       364 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 597 k
Is this ok [y/N]:

Now why does it want to do that? ORBit2 doesn't depend on ORBit2-devel.
Those other things should already have access to ORBit2-devel in the 
fake package.










Comment 6 Seth Vidal 2005-05-12 02:53:29 EDT
run: rpm -Va --nofiles --nomd5 

on your system.

tell me what, if anything, it reports.

thanks
Comment 7 Ivan Gyurdiev 2005-05-12 03:00:02 EDT
Unsatisfied dependencies for libquicktime-0.9.3-0.lvn.2.3.i686: libraw1394.so.5
Unsatisfied dependencies for SDL_sound-1.0.1-0.lvn.1.3.i386: libFLAC.so.4
Unsatisfied dependencies for xine-lib-1.0.0-0.lvn.3.3.i386: libFLAC.so.4


mmm.. I better fix those 
Comment 8 Rahul Sundaram 2005-06-21 07:02:04 EDT

Awaiting more information
Comment 9 Seth Vidal 2005-07-29 14:27:54 EDT
closing for now
reopen if we get news

Note You need to log in before you can comment on or make changes to this bug.