Bug 151010 - SCSI_DC395x not set for FC kernels
SCSI_DC395x not set for FC kernels
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-13 19:12 EST by Tethys
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 05:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2005-03-13 19:12:10 EST
Description of problem:
The FC kernels don't include support for Tekram DC395x SCSI controllers

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

The driver is marked as experimental. However, I've been using it since
the 2.4 days, and have found it to be extremely robust under both 2.4 and
2.6 kernels (I'm currently using a home built 2.6.10 kernel with it). Since
it's demonstrably stable, at least for my hardware, why not include it? I've
been using it for disks, a CD writer and a scanner, so it's been getting
coverage of a fairly respectable range of SCSI devices.

Also, the project objectives include:

   5. Be on the leading edge of open source technology, by adopting and
      helping develop new features and version upgrades.

"Leading edge" and "new features" would tend to imply that experimental
drivers should be actively encouraged. Particularly when, as in this case,
they're actually very stable.
Comment 1 Dave Jones 2005-07-15 14:50:17 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Tethys 2005-07-15 15:03:04 EDT
I'm guessing this was a blanket update to all your kernel related bugs, but
anyway, yes, it's still a problem with FC4.
Comment 3 Dave Jones 2005-07-15 16:18:35 EDT
yes, it was a blanket comment, thanks for the update though.
I've just committed a change to FC3/FC4/rawhide, all being well
(ie, as long as it compiles) this will be in the next updates.
Comment 4 Dave Jones 2005-07-15 17:39:46 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 5 Tethys 2005-10-30 19:18:10 EST
Just FYI, this now works fine with recent kernels (2.6.13-1.1532_FC4smp,
for example).

Note You need to log in before you can comment on or make changes to this bug.