Bug 151048 - Yum crashes after update to SQLite-3
Yum crashes after update to SQLite-3
Status: CLOSED DUPLICATE of bug 151047
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 08:21 EST by Naadir Jeewa
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 08:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naadir Jeewa 2005-03-14 08:21:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Since the sqlite3 package has been replaced by sqlite-3, Yum fails to process the package list after downloading metadata


Version-Release number of selected component (if applicable):
yum-2.3.1-2 sqlite-3.1.2-1 python-sqlite-1.1.6-1

How reproducible:
Always

Steps to Reproduce:
1. Run yum update
  

Actual Results:  Setting up Update Process
Setting up Repos
newrpms                   100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 107 kB    00:00
newrpms   : ################################################## 385/385
Added 385 new packages, deleted 0 old in 2.07 seconds
primary.xml.gz            100% |=========================| 146 kB    00:00
freshrpms : ################################################## 471/471
Added 471 new packages, deleted 0 old in 1.57 seconds
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 72, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 462, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 960, in updatePkgs
    self.doUpdateSetup()
  File "__init__.py", line 228, in doUpdateSetup
  File "sqlitesack.py", line 225, in returnObsoletes
  File "/usr/src/build/539311-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py", line 104, in __getitem__
KeyError: 'PACKAGES.PKGID'


Expected Results:  Pulling of upgraded headers

Additional info:
Comment 1 Seth Vidal 2005-03-14 08:59:46 EST

*** This bug has been marked as a duplicate of 151047 ***

Note You need to log in before you can comment on or make changes to this bug.