Bug 151055 - PHP isn't rebuildable against Rawhide
PHP isn't rebuildable against Rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 09:14 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 05:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-14 09:14:42 EST
Description of problem:
PHP isn't rebuildable against Rawhide, fails with this error messages:

--- snipp ---
[...]
/bin/sh /usr/src/redhat/BUILD/php-5.0.3/build-cgi/libtool --silent --preserve-
dup-deps --mode=compile gcc  -Iext/openssl/ -I/usr/src/redhat/BUILD/php-
5.0.3/ext/openssl/ -DPHP_ATOM_INC -I/usr/src/redhat/BUILD/php-5.0.3/build-
cgi/include -I/usr/src/redhat/BUILD/php-5.0.3/build-cgi/main -
I/usr/src/redhat/BUILD/php-5.0.3 -I/usr/src/redhat/BUILD/php-5.0.3/build-
cgi/Zend -I/usr/include/libxml2 -I/usr/kerberos/include -
I/usr/include/freetype2 -I/usr/include/imap -I/usr/src/redhat/BUILD/php-
5.0.3/ext/mbstring/oniguruma -I/usr/src/redhat/BUILD/php-
5.0.3/ext/mbstring/libmbfl -I/usr/src/redhat/BUILD/php-
5.0.3/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/include/ncurses -
I/usr/include/pspell -I/usr/src/redhat/BUILD/php-5.0.3/main -
I/usr/src/redhat/BUILD/php-5.0.3/Zend -I/usr/src/redhat/BUILD/php-5.0.3/TSRM -
I/usr/src/redhat/BUILD/php-5.0.3/build-cgi/  -I/usr/src/redhat/BUILD/php-
5.0.3/build-cgi/TSRM  -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -
march=i386 -mtune=pentium4 -Wall -fno-strict-aliasing  -prefer-non-pic -c 
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c -o ext/openssl/xp_ssl.o
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c: In function 
'php_openssl_sockop_read':
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: error: syntax error 
before '(' token
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: error: 
'__nbytes_val' undeclared (first use in this function)
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: error: (Each 
undeclared identifier is reported only once
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: error: for each 
function it appears in.)
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: warning: passing 
argument 1 of 'read' makes integer from pointer without a cast
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:219: error: syntax error 
before ')' token
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c: At top level:
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:223: error: syntax error 
before '->' token
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c: In function 
'php_openssl_tcp_sockop_accept':
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:460: warning: enumeration 
value 'STREAM_CRYPTO_METHOD_SSLv2_SERVER' not handled in switch
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:460: warning: enumeration 
value 'STREAM_CRYPTO_METHOD_SSLv3_SERVER' not handled in switch
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:460: warning: enumeration 
value 'STREAM_CRYPTO_METHOD_SSLv23_SERVER' not handled in switch
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:460: warning: enumeration 
value 'STREAM_CRYPTO_METHOD_TLS_SERVER' not handled in switch
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c: In function 
'php_openssl_sockop_set_option':
/usr/src/redhat/BUILD/php-5.0.3/ext/openssl/xp_ssl.c:500: warning: unused 
variable 'rfds'
make: *** [ext/openssl/xp_ssl.lo] Error 1
make: *** Waiting for unfinished jobs....
Fehler: Bad exit status from /var/tmp/rpm-tmp.92807 (%build)
--- snapp ---

Version-Release number of selected component (if applicable):
php-5.0.3-3

How reproducible:
Everytime, try to rebuild PHP.

Actual results / Expected results:
PHP should be compileable.
Comment 1 Joe Orton 2005-03-20 05:33:58 EST
Marking this WONTFIX this since glibc has been changed to avoid the read() etc
macros.

Note You need to log in before you can comment on or make changes to this bug.