Bug 151075 - texi2dvi from texinfo package fails if tex is not installed
texi2dvi from texinfo package fails if tex is not installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 11:49 EST by Jeff Sheltren
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.8-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 12:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sheltren 2005-03-14 11:49:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
When running texi2dvi, an error message is displayed indicating that
it needs a working 'tex' binary installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./usr/bin/texi2dvi -o blah.dvi blah
2.
3.
    

Actual Results:  Error message explaining that 'tex' is not found

Expected Results:  Should have processed file and created dvi file

Additional info:

texinfo should have a requires for tetex since the texi2dvi script
depends upon the presence of a tex binary.  Also (probably another
bug), the error message refers to apt-get and the package tetex-bin
rather than tetex which will probably confuse people.

Error message:
$ /usr/bin/texi2dvi -o blah.dvi blah
You don't have a working TeX binary (tex) installed anywhere in
your PATH, and texi2dvi cannot proceed without one.  If you want to use
this script, you'll need to install TeX (if you don't have it) or change
your PATH or TEX environment variable (if you do).  See the --help
output for more details.

For information about obtaining TeX, please see http://www.tug.org.  If
you happen to be using Debian, you can get it with this command:
  apt-get install tetex-bin
Comment 1 Tim Waugh 2005-03-14 12:06:44 EST
Fixed in texinfo-4.8-4.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.