Bug 151077 - clusterfs.sh, fs.sh: killMountProcesses broken, blame fuser
Summary: clusterfs.sh, fs.sh: killMountProcesses broken, blame fuser
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-14 17:02 UTC by Derek Anderson
Modified: 2009-04-16 20:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 20:45:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2005-03-14 17:02:01 UTC
Description of problem:
In both the clusterfs.sh and fs.sh, if you need to force unmount a
filesystem, calling killMountProccesses(), you will always fail.  This
is because the fuser (will have to check lsof next, I suppose) is not
functioning the way it used to.  Don't know why (device-mapper?).

[root@link-12 gfs1]# mount | grep gfs
/dev/mapper/VG1-LV1 on /mnt/gfs1 type gfs (rw,noatime,nodiratime)
[root@link-12 gfs1]# fuser -vm /mnt/gfs1

                     USER        PID ACCESS COMMAND
/mnt/gfs1            root      29425 ..c..  bash
[root@link-12 gfs1]# fuser -vm /dev/mapper/VG1-LV1
[root@link-12 gfs1]#

Version-Release number of selected component (if applicable):
rgmanager-1.9.24-0

How reproducible:


Steps to Reproduce:
1. Set force_unmount=1 if using clusterfs
2. Start clusterfs service
3. Put a pid on the fs
4. Try to relocate it
  
Actual results:
Fails to properly kill pids on fs.

Expected results:
Pids killed, relocate successful.

Additional info:

Comment 1 Lon Hohberger 2005-03-21 21:08:23 UTC
Fixed in CVS

Comment 2 Lon Hohberger 2005-05-06 20:45:37 UTC
These have been fixed in CVS for some time; closing


Note You need to log in before you can comment on or make changes to this bug.