Bug 151078 - utmp corruption on telnet server
utmp corruption on telnet server
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 12:23 EST by Steve Hitterdal
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hitterdal 2005-03-14 12:23:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050301 Firefox/1.0.1

Description of problem:
We are running a telnet server on Redhat Enterprise Linux 3 with 300+ users that runs into the following problem:

After the server has been running for a period of time (anywhere from 24 hours to 7 days) it encounters a problem where users login to the system and they are reported as someone else.  This can be seen in /var/log/messages where users will login and the following message will appear:
 
login(pam_unix)[10760]: session opened for user xxxxx by yyyy
 
where xxxx is the actual username and yyyy is who the operating system sees that
user as.  If you login as root at this time and run the command who -m, it
returns a blank line.

I had a service request opened for this issue and it was suggested that I report this information as a utmp corruption bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start the telnet server through xinetd
2. wait for problem to occur
3.
  

Additional info:
Comment 1 Karel Zak 2005-03-31 05:23:49 EST
Please, update to the latest telnet-server version. In the version >=
1:0.17-26.EL3.1 is bugfix:

* Thu Jan 13 2005 Jason Vas Dias <jvdias@redhat.com> - 1:0.17-26.EL3.1
- bug 143929 / 145004 : fix race condition in telnetd on wtmp lock
- when cleanup() is entered from main process and in signal
- handler

I'm not 100% sure, but it's possible that there is a connection between your
problem and wtmp lock problem.
Comment 2 Steve Hitterdal 2005-03-31 09:09:32 EST
We have been testing the 2.4.21-31 beta kernel and the telnet server has been
running for 7 days without encountering utmp corruption.  We will continue to
monitor the server but we are hopeful that this can be a resolution to our problem.
Comment 3 Steve Hitterdal 2005-04-12 10:31:51 EDT
The 2.4.21.31 beta kernel had utmp corruption after an uptime of 13 days.  We
have upgraded to the telnet-server-0.17-26.EL3.2 and will report if utmp
corruption occurs with the new telnet server.
Comment 4 Karel Zak 2005-09-08 06:42:20 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 

Note You need to log in before you can comment on or make changes to this bug.