Bug 151081 - redhat-config-cluster clobbers /etc/cluster.xml symlink
Summary: redhat-config-cluster clobbers /etc/cluster.xml symlink
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-14 18:13 UTC by Andrew C. Dingman
Modified: 2009-04-16 20:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-765
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 14:54:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:765 normal SHIPPED_LIVE redhat-config-cluster bug fix update 2005-09-30 04:00:00 UTC

Description Andrew C. Dingman 2005-03-14 18:13:20 UTC
Description of problem: redhat-config-cluster does not follow symlinks when
modifying cluster.xml.


Version-Release number of selected component (if applicable): 1.0.3-1


How reproducible: Move cluster.xml to another location, and symlink to
/etc/cluster.xml. Modify with redhat-config-cluster. The symlink will be
replaced with a new, regular file, and the target will be unmodified.


Steps to Reproduce:
1. cp /etc/cluster.xml /shared/filesystem/
2. ln -sf /shared/filesystem/cluster.xml /etc/
3. redhat-config-cluster # alter config slightly
4. ls -l /etc/cluster.xml
   -rw-------    1 root     root         1761 Mar 14 11:33 /etc/cluster.xml

  
Actual results:
Symlink to desired location of cluster.xml is replaced by a regular file
containing the new configuration.

Expected results:
Target of symlink is replaced by regular file containing the new configuration.

Additional info:
Since all my cluster members are also part of a GFS cluster, it would be
convenient to place a shared cluster.xml on a shared file system, and let
/etc/cluster.xml be a symlink. I am doing this with several other configuration
files successfully, but this unfortunate behavior of redhat-config-cluster
defeats my strategy. Please fix in a future version.

Comment 1 Jim Parsons 2005-09-02 19:50:56 UTC
Fixed in U6 candidate build 1.0.8-1.0

Comment 2 Red Hat Bugzilla 2005-09-30 14:54:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-765.html



Note You need to log in before you can comment on or make changes to this bug.