Bug 151091 - netfs.sh status broken, causing uneccesary failovers
Summary: netfs.sh status broken, causing uneccesary failovers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-14 20:01 UTC by Derek Anderson
Modified: 2009-04-16 20:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 20:45:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2005-03-14 20:01:20 UTC
Description of problem:
The status of the netfs.sh is currently calling this:
  isMounted ${OCF_RESKEY_device} ${OCF_RESKEY_mountpoint}

This fails with a usage becuase isMounted wants the full NFS path
including the hostname of the exporter, like $host:$export.  This is
causing the entire group to fail/relocate/restart, depending on what
you have recovery= set to.

So if you change it to:
    isMounted ${OCF_RESKEY_host}:${OCF_RESKEY_export} 
${OCF_RESKEY_mountpoint}

It seems to be working correctly.  Haven't yet tried it with multiple
netfs services.

-----------------
2) The Usage for isMounted is also kind of mangled.  "fullpathice"?
    "Usage: isMounted fullpathice mount_point"


-----------------
  <resources>
    <netfs name="Net_FS" mountpoint="/mnt/nfs1" host="link-01"
export="/tmp" fstype="nfs" options="sync"/>
  </resources>
  <resourcegroup ref="FOO">
    <netfs ref="Net_FS"/>
  </resourcegroup>

Version-Release number of selected component (if applicable):
rgmanager-1.9.24-0

How reproducible:


Steps to Reproduce:
1. Set up a netfs service
2. Enable it
3. Wait 5 minutes for routine status check
  
Actual results:
Fails.

Expected results:
Passes, since the service is in fact fine.


Additional info:

Comment 1 Lon Hohberger 2005-03-21 15:01:42 UTC
You're right -- should be host:export

start and stop both call isMounted in the netfs properly; the only black sheep
appears to be status.

Comment 2 Lon Hohberger 2005-03-21 21:08:28 UTC
Fixed in CVS

Comment 3 Lon Hohberger 2005-05-06 20:45:55 UTC
These have been fixed in CVS for some time; closing


Note You need to log in before you can comment on or make changes to this bug.