Bug 151098 - gmp isn't rebuildable against Rawhide
gmp isn't rebuildable against Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 16:29 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.4-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 09:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-14 16:29:56 EST
Description of problem:
gmp isn't rebuildable against Rawhide, fails with this error messages:

--- snipp ---
[...]
make[2]: Entering directory `/usr/src/redhat/BUILD/gmp-4.1.4/base/mpfr/tests'
make  reuse tabs tadd tagm tcan_round tcmp tcmp2 tcmp_ui tdiv tdiv_ui tdump teq
texp tget_str tlog tconst_log2 tmul tmul_2exp tmul_ui tout_str tconst_pi tpow
trandom tround_prec tset_d tset_f tset_q tset_si tset_str tset_z tsqrt tsqrt_ui
tui_div tui_sub tswap ttrunc trint tisnan tget_d tatan tcosh tsinh ttanh tacosh
tasinh tatanh thyperbolic texp2 tfactorial tsub tasin tconst_euler tcos tsin
ttan tsub_ui tset tlog1p texpm1 tlog2 tlog10 tui_pow tpow3 tadd_ui texceptions
tfma thypot tacos
make[3]: Entering directory `/usr/src/redhat/BUILD/gmp-4.1.4/base/mpfr/tests'
gcc -DHAVE_CONFIG_H -I. -I../../../mpfr/tests -I../.. -I../../.. -I../../../mpfr
    -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -
mtune=pentium4 -ffloat-store -c `test -f '../../../mpfr/tests/reuse.c' || echo
'../../../mpfr/tests/'`../../../mpfr/tests/reuse.c
gcc -DHAVE_CONFIG_H -I. -I../../../mpfr/tests -I../.. -I../../.. -
I../../../mpfr    -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -
mtune=pentium4 -ffloat-store -c `test -f '../../../mpfr/tests/tabs.c' || echo
'../../../mpfr/tests/'`../../../mpfr/tests/tabs.c
In file included from ../../../mpfr/tests/tabs.c:27:
../../../mpfr/mpfr-test.h: In function 'mpfr_test_init':
../../../mpfr/mpfr-test.h:101: error: memory input 0 is not directly
addressable
../../../mpfr/mpfr-test.h: In function 'drand':
../../../mpfr/mpfr-test.h:112: warning: dereferencing type-punned pointer will
break strict-aliasing rules
make[3]: *** [tabs.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/usr/src/redhat/BUILD/gmp-4.1.4/base/mpfr/tests'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/gmp-4.1.4/base/mpfr/tests'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gmp-4.1.4/base/mpfr'
make: *** [check-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.77830 (%check)
--- snapp ---

Version-Release number of selected component (if applicable):
gmp-4.1.4-4

How reproducible:
Everytime, try to rebuild gmp.

Actual results / Expected results:
gmp should be compileable.
Comment 1 Robert Scheck 2005-03-23 09:42:59 EST
glibc-2.3.4-16's loosening at -D_FORTIFY_SOURCE=* didn't make any difference for
gmp (compared with other packages).
Comment 2 Robert Scheck 2005-03-31 16:50:13 EST
David Newman (from jesus.ox.ac.uk) sent me a patch, it's a bit of a dirty hack 
though, but works for him and for me. It looks like the fldcw instruction has 
to take a memory operand. Thank you to David also this way :)

--- gmp-4.1.4/mpfr/mpfr-test.h          2002-04-19 23:41:05.000000000 +0200
+++ gmp-4.1.4/mpfr/mpfr-test.h.gcc4     2005-03-30 13:30:22.000000000 +0200
@@ -42,7 +42,8 @@
 #endif
 #endif /* ifdef __CYGWIN32__ */
 #ifndef __setfpucw
-#define __setfpucw(cw) __asm__ ("fldcw %0" : : "m" (cw))
+#define __setfpucw(cw) do {unsigned long __cw = cw; __asm__ \
+("fldcw %0" : : "m" (__cw));} while (0)
 #endif /* ifndef __setfpucw */
 #endif /* __i386__ */
Comment 3 Robert Scheck 2005-04-19 09:33:15 EDT
Thank you for fixing in 4.1.4-6, closing now.

Note You need to log in before you can comment on or make changes to this bug.