Bug 15110 - SCSI CDROM mount failure
SCSI CDROM mount failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 16887 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-02 08:33 EDT by Michael Fawke
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:34:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fawke 2000-08-02 08:33:00 EDT
Since upgrading to kernel 2.2.16-3, the system is unable to mount the SCSI 
cdrom. The machine is an IBM PC320 Server, running dual P120, with an 
Adaptec AIC-7870 fast/wide controller on the board. The CDROM is an IBM-
CDRM00103 drive. While there is no problem with booting from the CDROM and 
performing an update, the following messages appear in the log after 
attempting to mount a CD :

VFS: Disk change detected on device sr(11,0)
(scsi0:0:1:-1) Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x111
(scsi0:0:1:-1) Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x110
(scsi0:0:1:-1) Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x111
(scsi0:0:1:-1) Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x112
(scsi0:0:1:-1) Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x112
scsi : aborting command due to timeout : pid 3382, scsi0, channel 0, id 0, 
lun 0 Write (10) 00 00 02 3c 90 00 00 02 00 
SCSI host 0 abort (pid 3382) timed out - resetting
SCSI bus is being reset for host 0 channel 0.
(scsi0:0:0:0) Synchronous at 10.0 Mbyte/sec, offset 15.
sr0: CD-ROM not ready.  Make sure you have a disc in the drive.
CD-ROM I/O error: dev 0b:00, sector 64
isofs_read_super: bread failed, dev=0b:00, iso_blknum=16, block=32
VFS: Disk change detected on device sr(11,0)
(scsi0:0:2:0) Synchronous at 20.0 Mbyte/sec, offset 8.
(scsi0:0:6:0) Synchronous at 10.0 Mbyte/sec, offset 15.

The first time this problem occured, the following appeared in the log, 
which has not shown up for the attempt above.

Aug  2 21:29:19 BigBox kernel: sr0: CD-ROM error: [valid=0] Info fld=0x0, 
Current sr0b:00: sense key Illegal Request 
Aug  2 21:29:19 BigBox kernel: Additional sense indicates Invalid field in 
cdb 
Aug  2 21:29:19 BigBox kernel: command was: Read (10) 00 00 00 00 10 00 00 
01 00  

This problem occurs in both SMP and uni-processor modes. Bug 11387 has 
some similarities...
Comment 1 Michael Fawke 2000-08-04 07:06:24 EDT
Hmmm - several CDROM fixes in the 2.2.17-pre's noted at www.linuxhq.com
Comment 2 Michael K. Johnson 2000-08-04 16:21:56 EDT
Alan, do we need to pull more patches from 2.2.17preFOO?
Comment 3 Michael Fawke 2000-08-05 21:22:55 EDT
Well - I've just discovered that I cannot mount an IDE CD-ROM either! 

From Dmesg (log contains the same details):

VFS: Disk change detected on device ide1(22,64)
VFS: Disk change detected on device ide1(22,64)
VFS: Disk change detected on device ide1(22,64)
attempt to access beyond end of device
16:40: rw=0, want=33, limit=0
dev 16:40 blksize=1024 blocknr=32 sector=64 size=1024 count=1
isofs_read_super: bread failed, dev=16:40, iso_blknum=16, block=32
attempt to access beyond end of device
16:40: rw=0, want=33, limit=0
dev 16:40 blksize=1024 blocknr=32 sector=64 size=1024 count=1
isofs_read_super: bread failed, dev=16:40, iso_blknum=16, block=32
attempt to access beyond end of device
16:40: rw=0, want=33, limit=0
dev 16:40 blksize=1024 blocknr=32 sector=64 size=1024 count=1
isofs_read_super: bread failed, dev=16:40, iso_blknum=16, block=32
attempt to access beyond end of device
16:40: rw=0, want=33, limit=0
dev 16:40 blksize=1024 blocknr=32 sector=64 size=1024 count=1
isofs_read_super: bread failed, dev=16:40, iso_blknum=16, block=32
Comment 4 G. Bersano 2000-08-21 12:03:26 EDT
I had a similar problem (...Unexpected busfree, LASTPHASE = 0x40, SEQADDR = 0x110...)
and it went away with aic7xxx driver 5.1.31. See bug # 14460.
Comment 5 Jón Fairbairn 2000-08-26 05:36:24 EDT
*** Bug 16887 has been marked as a duplicate of this bug. ***
Comment 6 aezekiel 2000-12-01 19:47:40 EST
I have the same issue (failure to read a data CD) with an IDE CD-ROM and kernel 
2.2.16-3 on RedHat 6.2. I gather newer released kernels fix this. Will there be 
a newer set of kernel RPMs for 6.2 or a fix to address this?
Comment 7 Michael Fawke 2000-12-02 07:22:33 EST
The problem went away with release 7, kernel 2.2.16-22. I should have posted 
this before - the IDE problem seemed to be with specific CD-Rom's. I can't 
remember which ones now, so I cannot go back and check :(

Note You need to log in before you can comment on or make changes to this bug.