Bug 151113 - pwd prompt window needs system name
pwd prompt window needs system name
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 18:15 EST by Don Russell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 11:27:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to show uname info in passwd window (5.18 KB, patch)
2005-10-12 11:29 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Don Russell 2005-03-14 18:15:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
After the screensaver kicks in and I move the mouse or pressa key, I'm propted for a userid and password. (Of course)

It would be helpful for that prompting window to include the name of the machine (uname -n)

I have several FC3 machines connected to a single screen/keyboard/mouse with a KVM switch. Since the logon prompts all look the same, I can't tell (without looking at the KVM switch) which one I'm about to log on to.

Having the network node name (uname -n) displayed would help a lot.

Version-Release number of selected component (if applicable):
4.18

How reproducible:
Always

Steps to Reproduce:
1. Let the screen save kick in
2. move the mouse to be prompted for userid/password
3.
  

Actual Results:  I was prompted for userid/password, but no indication of which system.


Expected Results:  It would be helpful to have the node name included (uname -n)

Additional info:
Comment 1 Don Russell 2005-03-18 17:34:52 EST
If you tell me which individual source file builds the password prompt window,
I'd be happy to make a new version/patch for it and include it here.

The code I want to add looks something like:

#include <sys/utsname.h>

struct utsname name ;
char *nodename ;

if (uname(&name) == -1)
   nodename = "*unknown*" ;
else
   nodename = name.nodename ;

Then include the nodename string on the password prompt screen.

In the mean time I'll keep looking through the source for xscreensaver to see if
I can find what I'm looking for, but I beleive this is the basic solution.

Cheers,
Don
Comment 2 Don Russell 2005-03-18 17:41:32 EST
changed hardware platform to "all" from "i686" since this really applies to all
platforms running this code, not just mine.

Don
Comment 3 Mamoru TASAKA 2005-10-12 11:29:26 EDT
Created attachment 119840 [details]
patch to show uname info in passwd window

Hello.
xlockmore (now in fedora-extras) follows this behavior: i.e. in password prompt

window, it shows the hostname info.
I made a EXPERIMENTAL patch to show uname info on password prompt window. 
I don't understand the source of xscreensaver completely: I refered to the
other
parts of source code. Don, please try and verify this patch if you like.

Note1: By default, showing uname info is disabled. To enable it, change the 
Boolean value of passwd.uname in XScreenSaver to True.
Note2: This patch is made for xscreensaver-4.22-18 in rawhide. This patch
doesn't work for xscreensaver-4.18.
Comment 4 Mamoru TASAKA 2005-10-12 11:53:28 EDT
In the patch above, including <ctype.h> in lock.c is for removing warning
againt isprint(3) by xscreeensaver-4.22-ignore-unprintable-characters.patch,
not related to uname issue.
Comment 5 Mamoru TASAKA 2006-01-23 08:35:05 EST
This behavior (enhancement) that lock screen shows uname info is included in rpm
rawhide version 4.23-1. I think this requirement can be closed now.  
Comment 6 Ray Strode [halfline] 2006-01-23 11:27:32 EST
Thanks Mamoru,
And thanks for all your work on xscreensaver.

Jamie, you may want to check out the latest rawhide rpm of xscreensaver.  It
includes a lot of patches from Mamoru for various things.

Note You need to log in before you can comment on or make changes to this bug.