Bug 151122 - gnuplot-emacs is missing ...-init.el file
gnuplot-emacs is missing ...-init.el file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 22:01 EST by Michal Jaegermann
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-02 06:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-03-14 22:01:49 EST
Description of problem:

Not strictly a bug but it does not follow a pattern used by
other "extra" emacs packages.  There is no file like

/usr/share/emacs/site-lisp/site-start.d/gnuplot-init.el

with a content, say:

(autoload 'gnuplot-mode "gnuplot" "gnuplot major mode" t)
(autoload 'gnuplot-make-buffer "gnuplot"
  "open a buffer in gnuplot-mode" t)
(setq auto-mode-alist (append '(("\\.gp$" . gnuplot-mode))
			      auto-mode-alist))

A user is basically expected to go through comments in gnuplot.el
and create something like that on her/his own.

Version-Release number of selected component (if applicable):
gnuplot-emacs-4.0.0-4
Comment 1 Phil Knirsch 2005-09-02 06:32:16 EDT
Looks like a good idea, will include in the next gnuplot development build.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.