Bug 151135 - mtools aren't rebuildable against Rawhide
Summary: mtools aren't rebuildable against Rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mtools   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-15 11:15 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.9.9-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 11:43:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-03-15 11:15:46 UTC
Description of problem:
mtools aren't currently rebuildable against Rawhide, dies with 
multiple errors; caused by the new glibc, I guess:

--- snipp ---
[...]
+ make
gcc  -DHAVE_CONFIG_H -DSYSCONFDIR=\"/etc\" -DCPU_i686 -DVENDOR_redhat 
-DOS_linux_gnu  -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -
march=i386 -mtune=pentium4 -Wall -I.  -I.   -c buffer.c
buffer.c:151:13: error: macro "read" passed 4 arguments, but takes 
just 3
buffer.c: In function 'buf_read':
buffer.c:148: warning: assignment makes integer from pointer without 
a cast
buffer.c:207:61: error: macro "read" passed 4 arguments, but takes 
just 3
buffer.c: In function 'buf_write':
buffer.c:207: warning: assignment makes integer from pointer without 
a cast
make: *** [buffer.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.28925 (%build)
--- snapp ---

Version-Release number of selected component (if applicable):
mtools-3.9.9-11

How reproducible:
Everytime, try to rebuild mtools.

Actual results / Expected results:
mtools should be rebuildable.

Comment 1 Tim Waugh 2005-03-15 11:43:51 UTC
Fixed in mtools-3.9.9-12.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.