Bug 151170 - Unable to bind to netlink socket
Unable to bind to netlink socket
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-15 11:40 EST by Bart Vanbrabant
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 11:46:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Vanbrabant 2005-03-15 11:40:56 EST
Description of problem:
The haldaemon can't be started any more. When I start it with
--daemon=no and --verbose=yes I get this:

17:35:16.855 [I] hald.c:498: hal 0.5.0.cvs20050310
17:35:16.855 [I] hald.c:502: Will not daemonize
17:35:16.877 [I] osspec.c:305: sysfs mount point is '/sys'
17:35:16.884 [I] osspec.c:310: proc mount point is '/proc'
*** [DIE] osspec.c:osspec_init():328 : Unable to bind to netlink socket

I get not that has something to do with hal in dmesg. When I run hal
with strace I get these lines at the end:

munmap(0xb7ed5000, 4096)                = 0
socket(PF_NETLINK, SOCK_DGRAM, 15)      = 7
getpid()                                = 25818
bind(7, {sa_family=AF_NETLINK, pid=25818, groups=ffffffff}, 12) = -1
EPERM (Operation not permitted)
fstat64(1, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb7ed5000
write(1, "*** [DIE] osspec.c:osspec_init()"..., 72) = 72
munmap(0xb7ed5000, 4096)                = 0
exit_group(1)                           = ?

I'm running the latest version of fedora from rawhide.

Version-Release number of selected component (if applicable):
hal-0.5.0.cvs20050310-1
Comment 1 David Zeuthen 2005-03-15 11:46:58 EST
You need --retain-privileges (look at the /etc/init.d/haldaemon init
script script)

Note You need to log in before you can comment on or make changes to this bug.