Bug 151174 - Some network utilities unable to resolve host
Summary: Some network utilities unable to resolve host
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-15 17:29 UTC by Mark Leyden
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 20:26:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Leyden 2005-03-15 17:29:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Connecting to Internet via Wireless, with PPTP VPN. 

After update from NetworkManager.i386 0.3.3-1.cvs20050119.2.fc3, ftp,
ping, curl, wget are unable to resolve hostnames. However, telnet and
yum resolve hostnames correctly.

Version-Release number of selected component (if applicable):
NetworkManager 0.3.4-1.1.0.fc3.i386

How reproducible:
Always

Steps to Reproduce:
1. NetworkManager running
2. Connect to Wireless Network and run PPTP.

    

Actual Results:  New DNS servers added to /etc/resolv.conf correctly.
Telnet, yum resolve hostnames correctly and can connect to remote servers.
FTP, ping, curl, firefox etc. do not resolve hostnames and are unable
to connect unless IP entered. 

Additional info:

Comment 1 Mark Leyden 2005-03-18 17:46:17 UTC
pptpconfig modifies /etc/resolv.conf, and I am assuing NetworkManager is unaware
of the changes to DNS.

Comment 2 Dan Williams 2005-03-22 06:09:15 UTC
More than likely you're correct.  In the perfect world, only NetworkManager should touch resolv.conf 
since it may be using caching nameserver configuration which would be destroyed by pptpconfig.  
pptpconfig must execute a script of some sort to modify resolv.conf maybe?  if so, this script needs to 
be changed and we need to add an API to NetworkManager to allow other programs like pptpconfig and 
VPN clients to update DNS information via NetworkManager.

Comment 3 Dan Williams 2005-05-16 20:26:41 UTC
I'm going to punt to pptpconfig, it should be a bit more intelligent about
modifying resolv.conf.  But if you run pptpconfig after connection to a wireless
network, and close the connection before changing networks, you shouldn't run
into problems.

pptpconfig's script should run 'nscd -i hosts' after it touches /etc/resolv.conf
and that may make most utilities aware of the changes.


Note You need to log in before you can comment on or make changes to this bug.