Bug 151181 - installation kernel doesn't recognize SATA drives on VIA K8T890
installation kernel doesn't recognize SATA drives on VIA K8T890
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-15 14:08 EST by Dominik Mierzejewski
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 22:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Mierzejewski 2005-03-15 14:08:56 EST
Description of problem:
During initial stage of installation, the kernel does recognize the
VIA VT6420 SATA controller, but it seems to ignore the disk (saying
something like "unsupported device, drive ignored", so the installer
says "no disks available" later.
After installing a minimal version of fedora-devel and downgrading to
latest FC3 kernel, it still works, so I assume it's been fixed in
later kernels.

I'd very much like to see updated install images available.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
always

Steps to Reproduce:
1. Boot FC3 x86_64 CD or DVD
2. Start installation
  
Actual results:
No SATA hard drives are detected.

Expected results:
They should be detected.

Additional info:
Output from working kernel:
$ rpm -q kernel
kernel-2.6.10-1.770_FC3.x86_64
$ cat /var/log/dmesg
[...]
SCSI subsystem initialized
libata version 1.10 loaded.
sata_via version 1.0
ACPI: PCI interrupt 0000:00:0f.0[B] -> GSI 20 (level, low) -> IRQ 169
sata_via(0000:00:0f.0): routed to hard irq line 4
ata1: SATA max UDMA/133 cmd 0xC000 ctl 0xC402 bmdma 0xD000 irq 169
ata2: SATA max UDMA/133 cmd 0xC800 ctl 0xCC02 bmdma 0xD008 irq 169
ata1: dev 0 cfg 49:2f00 82:346b 83:7d01 84:4003 85:3469 86:3c01
87:4003 88:407f
ata1: dev 0 ATA, max UDMA/133, 312581808 sectors: lba48
ata1: dev 0 configured for UDMA/133
scsi0 : sata_via
ata2: dev 0 cfg 49:2f00 82:346b 83:7d01 84:4003 85:3469 86:3c01
87:4003 88:407f
ata2: dev 0 ATA, max UDMA/133, 312581808 sectors: lba48
ata2: dev 0 configured for UDMA/133
scsi1 : sata_via
isa bounce pool size: 16 pages
  Vendor: ATA       Model: ST3160827AS       Rev: 3.42
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 sda4 < sda5 >
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: ATA       Model: ST3160827AS       Rev: 3.42
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
SCSI device sdb: drive cache: write back
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
SCSI device sdb: drive cache: write back
 sdb: sdb1 sdb2
Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
$ /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc.: Unknown device 0238
00:00.1 Host bridge: VIA Technologies, Inc.: Unknown device 1238
00:00.2 Host bridge: VIA Technologies, Inc.: Unknown device 2238
00:00.3 Host bridge: VIA Technologies, Inc.: Unknown device 3238
00:00.4 Host bridge: VIA Technologies, Inc.: Unknown device 4238
00:00.5 PIC: VIA Technologies, Inc.: Unknown device 5238
00:00.7 Host bridge: VIA Technologies, Inc.: Unknown device 7238
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]
00:02.0 PCI bridge: VIA Technologies, Inc.: Unknown device a238
00:03.0 PCI bridge: VIA Technologies, Inc.: Unknown device c238
00:03.1 PCI bridge: VIA Technologies, Inc.: Unknown device d238
00:03.2 PCI bridge: VIA Technologies, Inc.: Unknown device e238
00:03.3 PCI bridge: VIA Technologies, Inc.: Unknown device f238
00:07.0 Ethernet controller: Marvell Technology Group Ltd.: Unknown
device 1fa7 (rev 07)
00:08.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A
IEEE-1394a-2000 Controller (PHY/Link)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID
Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge
[KT600/K8T800 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation: Unknown device
0141 (rev a2)
05:00.0 Ethernet controller: Marvell Technology Group Ltd. Marvell
Yukon 88E8053 Gigabit Ethernet 10/100/1000Base-T Adapter (rev 15)
Comment 1 Dave Jones 2005-07-15 15:28:51 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Dominik Mierzejewski 2005-07-22 11:34:05 EDT
As I wrote: there's no problem with current FC3 kernel. The problem is with the
kernel on the installation ISO image(s). That's why I asked about updated ISO
images, because I couldn't find any nor instructions for creating my own.
Comment 3 Dave Jones 2005-08-03 21:32:56 EDT
no, no updated isos, and I'm not aware of any howto's.
It would actually be useful though for such situations. I'll sit down the
installer folks some time and see if we can hash out something.

In the meantime, try FC4 ?
Comment 4 Dominik Mierzejewski 2005-12-15 21:08:55 EST
Too bad. Guess it's a WONTFIX then? ;) I'll try FC5.
Comment 5 Dave Jones 2005-12-15 22:56:00 EST
yeah, respinning a tree is non-trivial aparently.  Hopefully in FC6 time, we'll
be  able to offer just an updated boot.iso, with a kernel update on it, but
there's still quite a bit of groundwork to do.

In the meantime, if FC5test has the same problem, we'd love to hear about it.
Looking at the code in the current FC5 tree, there is support for the vt6420
controller, so hopefully you'll be all set with that.

If it doesn't work, feel free to reopen this, and adjust the bug to 'devel'.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.