Bug 151216 - SiS USB2 controller does not work with all devices
SiS USB2 controller does not work with all devices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-15 21:10 EST by Markus Huber
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 03:01:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Huber 2005-03-15 21:10:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Plugging in an USB2-device halts SCSI-detection and the USB-connectors
cannot be used anymore.

When the device is plugged in, booting halts at hardware detection.

This happens to me with an external USB disk and an Epson Photo 3170
scanner.

Same devices work wonderfully under an Intel USB2 device on my HP
z7000 notebook (FC3, latest patchlevel as the desktop where this is
happening).

Or is it a kernel issue? I am not an expert. Sorry.

Regards
Markus Huber

Version-Release number of selected component (if applicable):
udev-039-10.FC3.7

How reproducible:
Always

Steps to Reproduce:
1. Plugging in an USB2-device
2.
3.
    

Actual Results:  USB-connectors cannot be used or FC3 does not boot.

Expected Results:  USB2 devices should be automatically detected by
udev and usable under FC3.

Additional info:

# lspci -v
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0
Controller (prog-if 20 [EHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1801
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at e2002000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [50] Power Management version 2
Comment 1 Harald Hoyer 2005-04-27 06:04:05 EDT
most likely kernel and kudzu
Comment 2 Dave Jones 2005-07-15 14:13:19 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Markus Huber 2005-07-18 14:02:13 EDT
(In reply to comment #2)

> If you have updated to Fedora Core 4 since this bug was opened, and the problem
> still occurs with the latest updates for that release, please change the version
> field of this bug to 'fc4'.

I have upgraded to Fedora Core 4 and the problem does not occur with with FC4.

Thank you very much
Markus Huber

Note You need to log in before you can comment on or make changes to this bug.