Bug 151239 - "show details" must be clicked repeatedly
"show details" must be clicked repeatedly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 05:56 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 11:45:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stop rhgb switching back automatically when it was switched manually (1.16 KB, patch)
2005-11-10 07:17 EST, Mary Ellen Foster
no flags Details | Diff
Updated patch (1.24 KB, patch)
2005-11-15 12:29 EST, Mary Ellen Foster
no flags Details | Diff

  None (edit)
Description Need Real Name 2005-03-16 05:56:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020 Epiphany/1.4.4

Description of problem:
During boot, if I click "show details", I see the text boot script messages.
Then it changes back. I have to click "show details" again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-16 10:14:44 EST
Make that five times.
Four times before "staring pcmcia", and one time after that (not exactly sure when).

Tested by running from VMware under high load.
Comment 2 Need Real Name 2005-07-06 05:20:18 EDT
This is still broken.

To reproduce:
 1. Turn on the PC
 2. Click "Show details" when it shows
 3. Wait for it to switch back

So "Show details" is broken.
Comment 3 Mary Ellen Foster 2005-11-01 08:52:39 EST
I think what's going on is, rhgb is set up so that if something takes a while
(for me, it's ntpdate), it switches to details view, and then when that
time-consuming thing finishes it switches back to non-details view.

Problem: it does the "switch back after time-consuming event" thing even if you
had *manually* switched it to details view.

I think it should only automatically switch *back* from details view if it
automatically switched *to* details view.
Comment 4 Mary Ellen Foster 2005-11-10 07:17:52 EST
Created attachment 120877 [details]
Stop rhgb switching back automatically when it was switched manually

Here's a proposed patch against Rawhide rhgb to make it not automatically
switch back to "no details" view if it was manually switched to "details" view.
Comment 5 Ray Strode [halfline] 2005-11-10 10:45:41 EST
Thanks, Mary.

I've applied it. It should be in tomorrow's rawhide.
Comment 6 Mary Ellen Foster 2005-11-15 12:29:04 EST
Created attachment 121078 [details]
Updated patch

Okay, whoops, that previous patch didn't actually fix the issue. Here's an
updated version -- actually *tested* this time -- that I think should actually
make the change in the correct place.
Comment 7 Need Real Name 2006-01-20 15:45:25 EST
This seems to be broken in FC5T2.
Comment 8 Wade Mealing 2006-01-23 23:57:26 EST
Didnt see the problem in FC5T2.

When did you try ?
Comment 9 Need Real Name 2006-01-24 02:06:06 EST
I tried yesterday (is that what you mean?).
I'll try again later if rawhide has no broken dependencies.
Comment 10 Rahul Sundaram 2006-02-20 05:17:52 EST

Cant reproduce this problem on the latest rawhide. Assuming fixed. Closing
Comment 11 Need Real Name 2006-02-20 09:25:24 EST
I can.
Comment 12 Need Real Name 2006-03-02 05:58:56 EST
Still broken.
Comment 13 John Newbigin 2006-05-09 00:11:47 EDT
This is also a problem with EL4.  I see it with the delay on starting networking
(it takes ages for use to get DHCP addresses) and with ntpd (it's just slow).

It seems silly to file a new bug under EL4.
Comment 14 Red Hat Bugzilla 2007-02-05 14:21:49 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 15 Ray Strode [halfline] 2007-08-08 09:52:14 EDT
See bug 251321 for some relevant discussion
Comment 16 Ray Strode [halfline] 2007-08-08 11:45:10 EDT
This should be fixed in tomorrow's rawhide.  We can reopen it if there are any
further problems.

Note You need to log in before you can comment on or make changes to this bug.