Bug 151246 - get (in hash mode) blocks local file size at 2 GB when remote file greater than 2GB
Summary: get (in hash mode) blocks local file size at 2 GB when remote file greater th...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ftp   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-16 11:34 UTC by Simone Fiorentino
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: 0.17 Rel.27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 12:13:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simone Fiorentino 2005-03-16 11:34:19 UTC
Description of problem:
When getting files greater than 2GB in hash mode, the local file size blocks to 2GB

Version-Release number of selected component (if applicable):
ftp-0.17-17

How reproducible:
always

Steps to Reproduce:
1. ftp <ip>
2. bin
3. ha
4. get <filename>
  
Actual results:


Expected results:


Additional info:
mget in hash mode also blocks

Comment 1 Suzanne Hillman 2005-03-16 15:59:56 UTC
What do you mean by 'blocks to 2GB'? It won't get more than that much of a file?

Comment 2 Simone Fiorentino 2005-03-16 16:07:48 UTC
(In reply to comment #1)
> What do you mean by 'blocks to 2GB'? It won't get more than that much of a file?

Yes, when I get a remote file, the local file size is limited to 2GB...even if
the remote file size is bigger than 2 GB.

Comment 3 Suzanne Hillman 2005-03-16 21:38:21 UTC
I presume that, since you mention 'in hash mode', it works fine when not in hash
mode?

Comment 4 Simone Fiorentino 2005-03-17 08:04:09 UTC
(In reply to comment #3)
> I presume that, since you mention 'in hash mode', it works fine when not in hash
> mode?

Yes, it works fine when not in hash mode.

Comment 5 Petr Raszyk 2005-08-23 12:12:46 UTC
Patch netkit-ftp-0.17-longint.patch implemented.


Note You need to log in before you can comment on or make changes to this bug.