Bug 151264 - ooimpress dies on loading files
ooimpress dies on loading files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 10:44 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.9.85
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 14:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-03-16 10:44:12 EST
Description of problem:
impress is dieing on either loading an OO 1.1.x or 1.9.x presentation file from
the command line, via starting impress and loading or double clicking on the
file. It loads the file (the progress bar gets to the end), attempts to start
render and then dies.

Version-Release number of selected component (if applicable):
1.9.84

How reproducible:
Always

Steps to Reproduce:
1. Load an ooimpress file
2.
3.
  
Actual results:
The progress bar completes, the window clears, attempts to start to render and dies

Expected results:
The file should load and I can work on it.

Additional info:
Hi ho, hi ho, it's back to 1.9.80 I go :-(

;-p
Comment 1 Tom London 2005-03-16 17:14:32 EST
Yup. Fails for me too.
Comment 2 Caolan McNamara 2005-03-18 04:22:09 EST
This *might* go away in the next spin (underway), if not I'll get onto it.
Comment 3 Tom London 2005-03-18 11:28:47 EST
As requested, here is stack trace from this....

tom

'gdb /usr/lib/openoffice*/program/soffice.bin'.

Here is what I got:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208353984 (LWP 4099)]
0x05e09ff2 in Container::Insert ()
  from /usr/lib/openoffice.org1.9.84/program/libtl680li.so
(gdb)
(gdb) bt
#0  0x05e09ff2 in Container::Insert ()
  from /usr/lib/openoffice.org1.9.84/program/libtl680li.so
#1  0x05e0adb5 in Table::Insert ()
  from /usr/lib/openoffice.org1.9.84/program/libtl680li.so
#2  0xb58e061b in SvxForbiddenCharactersTable::~SvxForbiddenCharactersTable ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#3  0xb58e023d in SvxForbiddenCharactersTable::GetForbiddenCharacters ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#4  0xb5914356 in EdtAutoCorrDoc::GetPrevPara ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#5  0xb5916a26 in EdtAutoCorrDoc::GetPrevPara ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#6  0xb591773a in EdtAutoCorrDoc::GetPrevPara ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#7  0xb5919ab2 in EdtAutoCorrDoc::GetPrevPara ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#8  0xb5919af8 in EdtAutoCorrDoc::GetPrevPara ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#9  0xb58e8e0a in EditEngine::SetUpdateMode ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#10 0xb592e025 in Outliner::SetText ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#11 0xb5b2e04b in SdrTextObj::AdjustTextFrameWidthAndHeight ()
---Type <return> to continue, or q <return> to quit---
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#12 0xb5b2d7ec in SdrTextObj::NbcAdjustTextFrameWidthAndHeight ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#13 0xb5b29c2b in SdrTextObj::NbcSetOutlinerParaObject ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#14 0xb5b21734 in SdrObject::SetOutlinerParaObject ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#15 0xb5b981f8 in SdrPowerPointImport::ApplyTextObj ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#16 0xb4af10d4 in SdPage::getMainSequence ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#17 0xb5b8acac in SdrPowerPointImport::ReadObjText ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#18 0xb5b9c5fc in SdrEscherImport::ProcessObj ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#19 0xb4af25b8 in SdPage::getMainSequence ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#20 0xb5d1b2c0 in SvxMSDffManager::ImportShape ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#21 0xb5d1b3b0 in SvxMSDffManager::ImportObj ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
#22 0xb5b94787 in SdrPowerPointImport::ImportPage ()
  from /usr/lib/openoffice.org1.9.84/program/libsvx680li.so
---Type <return> to continue, or q <return> to quit---
#23 0xb4af569d in SdPage::getMainSequence ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#24 0xb4af6689 in SdPage::getMainSequence ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#25 0xb4af93a3 in SdPage::getMainSequence ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#26 0xb4a8aa2d in sd::DrawDocShell::ConvertFrom ()
  from /usr/lib/openoffice.org1.9.84/program/libsd680li.so
#27 0x0280ad31 in SfxObjectShell::DoLoad ()
  from /usr/lib/openoffice.org1.9.84/program/libsfx680li.so
#28 0x02835dd5 in SfxBaseModel::load ()
  from /usr/lib/openoffice.org1.9.84/program/libsfx680li.so
#29 0x0284fc11 in non-virtual thunk to SfxViewShell::~SfxViewShell() ()
  from /usr/lib/openoffice.org1.9.84/program/libsfx680li.so
#30 0x0201a0dc in component_getFactory ()
  from /usr/lib/openoffice.org1.9.84/program/libfwk680li.so
#31 0x0201a29a in component_getFactory ()
  from /usr/lib/openoffice.org1.9.84/program/libfwk680li.so
#32 0x0201a352 in component_getFactory ()
  from /usr/lib/openoffice.org1.9.84/program/libfwk680li.so
#33 0x01f71d52 in ?? ()
  from /usr/lib/openoffice.org1.9.84/program/libfwk680li.so
#34 0x0807cd55 in desktop::DispatchWatcher::executeDispatchRequests ()
---Type <return> to continue, or q <return> to quit---
#35 0x08075ceb in desktop::OfficeIPCThread::ExecuteCmdLineRequests ()
#36 0x0806dce9 in desktop::Desktop::OpenClients ()
#37 0x08070fda in desktop::Desktop::OpenClients_Impl ()
#38 0x008f6662 in Help::ShowTip ()
  from /usr/lib/openoffice.org1.9.84/program/libvcl680li.so
#39 0x00a3e611 in Window::DrawNativeControl ()
  from /usr/lib/openoffice.org1.9.84/program/libvcl680li.so
#40 0x045a5ec4 in ?? ()
  from /usr/lib/openoffice.org1.9.84/program/libvclplug_gen680li.so
#41 0x045cc1cc in SalDisplay::DispatchInternalEvent ()
  from /usr/lib/openoffice.org1.9.84/program/libvclplug_gen680li.so
#42 0x007e5407 in ?? ()
  from /usr/lib/openoffice.org1.9.84/program/libvclplug_gtk680li.so
#43 0x00619ad0 in ?? ()
#44 0x00619ad0 in ?? ()
#45 0x006198d0 in ?? ()
#46 0x047ee17c in ?? () from /usr/lib/libglib-2.0.so.0
#47 0x005bedac in __pthread_mutex_unlock_usercnt ()
  from /lib/tls/libpthread.so.0
#48 0x0479a6d0 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#49 0x0479846e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0x0479b476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#51 0x0479b958 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#52 0x007e50da in ?? ()
  from /usr/lib/openoffice.org1.9.84/program/libvclplug_gtk680li.so
#53 0x00000000 in ?? ()
(gdb)

I was trying to open a '.ppt' file.
Comment 4 Tom London 2005-03-20 13:32:28 EST
Works for me with openoffice.org-impress-1.9.85-1.

Thanks for the fix!
Comment 5 Paul F. Johnson 2005-03-20 14:00:16 EST
Yep. Seems good now. Changing status to closed.

Note You need to log in before you can comment on or make changes to this bug.